Kaseya Community

Private Remote Control - Number Keypad Not Working?

This question is answered

Can anyone confirm this?  Running latest v8.0.3, have downloaded latest remote control app and have deployed latest agents. When using private remote control I cannot use the number key pad on the keyboard in the remote session (works locally).  Tried this on a few different machines with same results.  In non-private mode, keypad works.  

Verified Answer
  • I'm getting the same thing and more specifically, it looks like the "NumLock" key doesn't pass through. So when I do a private session the use the number pad, it only sends the arrows, but when I do a public session the number pad only sends the numbers. Pressing the Numlock key in either instance doesn't seem to do anything.

    Sounds like a bug, can you enter a ticket?

    Max

All Replies
  • I'm getting the same thing and more specifically, it looks like the "NumLock" key doesn't pass through. So when I do a private session the use the number pad, it only sends the arrows, but when I do a public session the number pad only sends the numbers. Pressing the Numlock key in either instance doesn't seem to do anything.

    Sounds like a bug, can you enter a ticket?

    Max

  • Thanks Max.  Ticket opened - #47843 "Number Pad not working"

  • We've never had the numpad send numbers with the KRC system. I was hoping they'd fixed that in K8 but it seems not...

  • To clarify @GreyDuck - The number pad sends numbers in public sessions and sends arrows (left, right, up, down) in private sessions. As far as I can tell the issue is in the NumLock key not being sent.

    -Max

  • Max,

    Aha! Before the K8 upgrade, the number pad did nothing at all for us.

    I've just confirmed exactly what you've described. So, if nothing else, nobody can claim "it's just you."

  • BTW, I spoke to Dev on this and was told they're working on a fix.

    -Max

  • After updating from 6.5 to 8.0, I am getting a lot of complaints about this.  Has any progress been made?

  • Last night, by happy accident, I found how to turn on NumLock in a Kaseya Remote Session.  As many of you are aware, pressing the NumLock key does not work, however, pressing the WinKey+Pause/Break turns on Numlock on the remote side, and you can then use your number pad.



    Added as suggested answer
    [edited by: earleywine@appliedtech.us at 11:05 AM (GMT -8) on Jan 27, 2015]
  • This is just too comical, we've had the same issues and were told that it would go away with the latest release, we went to the latest release and the issue does not go away... and no official response... Kaseya is becoming a joke...

  • R9 claims to have fixed the numlock issue, according to R9 beta release notes.

  • rattrap

    This is just too comical, we've had the same issues and were told that it would go away with the latest release, we went to the latest release and the issue does not go away... and no official response... Kaseya is becoming a joke...

    I have to agree, very frustrating. After sitting on the sidelines for the May and September releases in 2014, we finally upgraded from R6.5 to R8 last week. The numlock issue hit our staff immediately. After working with K support, we were told we'd have to wait for R9 for a fix. I found this VERY disappointing. Clearly this is a bug. I feel strongly it should be fixed promptly, and as part of periodic patches. We should NOT have to wait for a new version.

    A new major version by nature (of any product) introduces the opportunity to deal with additional functionality changes, additional bugs, etc. New versions should be for major functionality changes, and major enhancements and additional features. Bug fixes should be prompt, and delivered via period patches. This bug should be patched immediately. Why do we have to wait for R9?

    Just my two cents.

    Warm Regards,

    Lloyd