Kaseya Community

Slowness with SBS 2011 Servers

This question is answered

Hey guys,

Our company has just upgraded to 7.0 last week and one issue I have found is that connecting into any client machines that are running Windows SBS 2011 using the new Remote Control tool is really slow. I'm talking 5-15 seconds worth of lag.

I haven't been able to replicate it on any other machines except 2 SBS 2011 machines we do have.

I have tried uninstalled the remote control tool and restarting the server and installing it again, but haven't found it makes any difference.

Has anyone else had this issue?
Is there a solution out there?

Kind Regards,

Daniel Murton

Verified Answer
  • Thanks for all your input. I've found the easy answer now:

    1. Right Click Desktop > Screen Resolution

    2. Advanced Settings

    3. Troubleshoot > Change Settings

    4. Hardware acceleration - change from Full to None

    5. OK

    You should notice the difference right away (without rebooting the server)

All Replies
  • It's not SBS. I can KRC into many, many SBS 2011 boxes with no issues.

    I have seen the same issue myself however, and in my case It's the display drivers on the box. Check task manager and notice the high %CPU time for the KRC services.

    The issue is KRC needs to encode the display data into a video stream; for this it uses the display drivers on the box. If the display drivers don't have any 2D acceleration (e.g. servers with Matrox ServerEngines drivers such as Intel S2600, S3420 series to name a few) then you get the high CPU and LAG problems you're talking about.

    The 'fix' is to revert to Microsoft "VGA" display drivers (and be stuck at 800x600 or whatever low resolution) instead of the Matrox drivers. If it's a VM, try using the Hypervisor's display drivers [by installing the guest drivers] - this seems to fix the issue too.

  • - sorry for the late response on this.  This is a known issue and has to do with really crappy video cards typically on servers.  We have a fix for these coming as part of the Sep30 release.  

  • Craig, that's great info, thanks. We'll try this "fix" on a few problematic servers...

  • Thanks for all your input. I've found the easy answer now:

    1. Right Click Desktop > Screen Resolution

    2. Advanced Settings

    3. Troubleshoot > Change Settings

    4. Hardware acceleration - change from Full to None

    5. OK

    You should notice the difference right away (without rebooting the server)

  • Worked with a customer with 2008 server that was still experiencing the slowness  issue post-R8 upgrade.   Direct KRC was slow, but interesting the Private session was faster!

    Used @murty's suggestion and it sped the system up significantly.  Thanks!