Kaseya Community

Legacy Remote Control ActiveX not Working in IE9

  • I opened support case CS161558 to address this issue, but I wanted to check with the community to see if this is a problem isolated to my system.

    As of today, any of my users running IE9 are having a problem with legacy remote control.  In IE9, the ActiveX control is not starting RDP or VNC automatically, the user must run the executable to start the remote control session.  This does not seem to be a problem on systems running IE10.

    Has anyone else seen this problem?

    Thanks in advance.

  • I have seen this on occasion - what I've been able to do to resolve it is to delete KaxRemote.dll from the %WINDIR%\Downloaded Program Files directory. Next time you try to launch legacy remote control, it should prompt you to install the ActiveX control. I will usually clear out my caches at the same time, but I think you can probably get away with just deleting that file.

  • Kerry, thanks for the suggestion.  That didn't correct the problem on several of our machines.  I will continue to work with Kaseya Support.  It doesn't sound like it is a widespread issue.

  • I am having this issue in Chrome as well as IE. Just submitted a ticket. Just to verify when I click the agent to remote it never actually loads the remote control viewer. I have to manually download and run. Then I am able to remote in.

  • lclark: Thanks for the update, I am glad to hear that it's not just my system.

  • Same here. It seems to have just started today or possibly over the weekend. (I wasn't testing over the weekend). It was working fine on Friday. You?

  • If you get resolution on this before me let me know. I'll do the same.

  • For me, folks started reporting it on Thursday.  It doesn't seem to be in issue in IE10 or in Chrome with the ActiveX for Chrome plugin installed.  It seems to be just IE9.

  • This is working fine for me. I am using IE9. I have always had to install the no-activeX.exe with chrome. I never used the chrome extension for activex.

  • It was working fine up until today. I have tested IE9 and chrome. Both have the issue.

  • In my case, this started happening after I upgraded to IE10. I had to delete the "kaxRemote.dll" and all "CONFLICT.x" folders under "Downloaded Program Files" to get it working again.

  • Yep That did it! Its Fixed. I just went into C:\windows\Downloaded Program Files  and deleted all of the CONFLICT.x folders and the KaxRemote.dll then logged back into the VSA and ran a remote connection and re-installed the KaxRemote.dll file. Worked like a charm.

  • SMason, That worked for me too.  Thank you!

  • I started having this same issue late last week.  When I went in to look at my C:\Windows\Downloaded Program Files folder is was empty already.  Has there been any word back from Kaseya on your ticket?  This is kind of annoying...  BTW, running IE10, Windows 8...

  • I guess your problem is kinda related to wrong settings in the Internet Options dialog box. Whichever web browser you're currnetly using, just do reset all Internet settings through the Internet Explorer's dialog box. Use a hotfix and if it doesn't work, continue with the steps given below. These steps are meant to reset Internet Explorer and other browsers settings.

    1. In IE, press Alt key of your keyboard.

    2. Click Tools ->> Internet Options.

    3. Click Advanced ->> Reset.

    4. Click Reset button.

    Hotfix: smitalandvikas.com/reginout