Kaseya Community

vnc viewer error: regopenkeyex: access is denied. (5)

This question has suggested answer(s)

Ive seen this error before and the fix was to right click and run IE as administrator however that is not working.

When trying to remote control a machine i have an employee that gets a vnc viewer error: regopenkeyex: access is denied. (5)

he is running windows 7 pro 64bit and IE9

All Replies
  • Usually the Run As Administrator trick works for me when I have that issue, but another thing you could try is to disable UAC on your computer. I have heard from a few people that if they turn off UAC and reboot, and try remote control again, it works. Then those same people turned UAC back on and rebooted (they preferred it on) and it still worked. Worth a shot. And a reboot or two.

  • Unfortunately UAC is already disabled.

  • Well, then - my suggestion is worth squat! I found this quote from another old thread here:

    community.kaseya.com/.../22366.asp

    where down the page a few posts, someone suggests to:

    "Right-click on the file C:\Users\%username%\AppData\Local\Temp\Low\KRlyCCon.exe, select Properties, Compatibility, and select the option to run this file in Windows XP SP2 compatibility mode. When you do remote control for the first time, you will be prompted to grant access to this program to home/work networks, and all networks. Check both boxes to grant network access to all locations."

    Also, have you by chance tried to Run As Administrator from a different account on the same computer?

  • Has anyone found a permanent solution to this?  I have an employee with the same problem.  In all other cases, running IE as admin once and starting remote control fixes the issue, but in this case, VNC only starts if IE is run as admin.

  • As a guess, even with UAC disabled, IE runs sandboxed AFAIK. Personally I like to run with UAC enabled both for safety, and as a way to get used to the pains that the users we're supporting are forced to deal with because of policy.

    Anyway, back on topic, a process inherits the security context that it was started from, so I've always used my K2 in an elevated IE. You can make it easier to swallow by making a nice shortcut to open your K2 in IE elevated by:

    1. Make a shortcut to IE (on the desktop or wherever)

    2. In the Target box, past the last double quote, add a space, then the URL of your K2 login, also in quotes (something like this "<path to ie>\iexplore.exe" "http://k2.url" )

    3. On the properties of the shortcut, hit Advanced... then check the box for run as admin

  • I have seen this issue before and have worked around it by resetting Internet Explorer (Options, Advanced, Reset both).

    Alternatively use a different user account to test the remote access function.

  • Thanks Topher, I did that with a slight difference and it worked!

    Right-click on the file C:\Users\%username%\AppData\Local\Temp\Low\KRlyCCon.exe, select Properties, Compatibility, tick “Run this program as an administrator”.

  • Try adding the VSA site to the trusted sites in IE.  That should take care of the issue.

  • Kaseya please just release liveconnect 6.4 to eliminate all these headaches :)

  • You have to run IE as admin once to allow it to install something and then its gone forever.

    Or just use chrome