Kaseya Community

Chrome and the "kaxRemote.dll failed to load!" mystery

This question has suggested answer(s)

OK, I give up. I have added the plug-in app to Chrome to allow it to load and run ActiveX programs, but nothing seems to work properly.

I have started to use Chrome for Kaseya because it is very slow and funky with IE9. The problem is, when you try to use the Remote Control tab or the old-school remote control in the Quick Launch (for those of us on v6.2 or are on v6.1 with Mark Sutherland's patch) you get that annoying "kaxRemote.dll failed to load!" error and you must download one of those noActiveX-95478987.exe files that have to be downloaded and run each time.

Has anyone gotten Chrome to play nice with the ActiveX controls? Having to load this file everytime is a real pain.

Thanks for any help!

Randy

All Replies
  • Hi Randy,

    I have tried and tried but been unable to get going either. I don't think its possible as active-x is microsoft and they have not allowed any other browsers to run it. Has anyone been able to get this going??

    I would prefer any browser over IE.

  • Some of my guys get around that problem with this: http://www.ietab.net/

  • The best thing now is to install the latest version of the KLC software, then you use the Desktop Access feature of KLC or the QuickConnect. It works perfectly well with Chrome. Just don't deploy new agent to Macs yet.

  • @Randy:

    Ho did you manage slow connection? KLC is pretty slow. No reduced colors, no copy & paste? Did you get these functions running in KLC?

  • I am hoping Kaseya changes the way this works.  At the moment the IE tab is no good as it uses IE (obviously) and all its wonderfully fast performance!  So for desktops we use the noactivex, but that soon gets annoying.

    My techs all have Chromebooks and we cannot use any of these remote control out in the field, so we use things like log me in to remote back to our desktops and then out to where we need to.

  • I've never gotten past it.  However, to be honest, I've kind of gotten used to just clicking the remote, clicking the "click here" for the manual load, and clicking the downloaded noActiveX-1234567.exe file.  Yes, it's three clicks instead of one.  But in all honesty, it only takes about 5 seconds extra work and I've just kind of gotten used to it.  

    A Chrome/Firefox direct plugin would be nice, though!

    To answer Kai's question: I'll use KLC for general viewing of what's going on, but any actual remote-control work and I'll go into the Remote Control -> Control Machine links because it actually runs the full RDP or VNC/KVNC client as a separate process, giving me the same level of control we used to have in Kaseya 2008 (can change color depth, copy/paste, etc.).  Yup, more clicks, but once you get used to it it really only takes a few seconds of work.  I've found lots to complain about in K6.1/6.2 but given some of the bigger issues I'm having ease of remote control just hasn't been one of them.

  • I have had the installed ActiveX plugin working for a while now and deployed a PortableApps version of Chrome to all our Office PC with the plugin already configured, 80% of our support desk use it without an issue, 10% use IE (they are special) the other 10% (Including myself) still use Chrome  but the RC doesn't work anymore, I have tried completely clearing the browsers history, deleting and redeploying the PortableApps version and reinstalling the plugin but nothing seems to fix it, I have to download the EXE every time I RC now, so annoying, especially when I look at other users in my Office with the same version of Chrome, pre-built by me and yet only I can't use it!

    If I find a fix, sorry, when I find a fix (or introduce my PC to a window which isn't made by MS) I'll let you know.

  • This one works flawlessly: https://chrome.google.com/webstore/detail/lgllffgicojgllpmdbemgglaponefajn

     

    Add a custom rule for CLSID: {AA299E98-6FB5-409F-99D3-D30D749F4864}

  • Hey SMason.

    How do you get working? Which steps? Just tried, but it doesn't work ... :(

  • yeah that plugin worked sweetly when it was version 1.2 however since then it hasn't worked. oddly we have one guy out of everyone that it does work for . i copied his chrome install but it made no difference. So for the rest of us it still doesn't work

  • First, I got the CLSID from "kasRmtHlp Class" in "%WINDIR%\Downloaded Program Files" (right-click, Properties)

    After you install the add-in for Chrome, you can go to Options, Extensions on left side, then click the Options link under "ActiveX for Chrome"

    I added a rule with the following details...

    Title: Kaseya

    Mode: CLSID

    Pattern: (retrieved from first step)

    User Agent: MSIE8

    Then I moved my rule all the way to the top of the list.

  • Hi SMason,

    Thank you so much for the help. I have been trying on this for ages and had given up but your method works without issue.

  • doesn't work for me cos i dont have a kasrmthlp ?

    any thoughts

  • don't worry i Fixed it . im sooooooo happy

  • SMason - You're a genius! Thank you helping me to resolve this very annoying issue! There's gonna be a little extra in your paycheck next week!  ;-)