Kaseya Community

Remote through RDP just sits at Connecting to 127.0.0.1:9100

  • We have one customers server that we can't remote into via Terminal Services through the Remote tab.

    the computer seems to be attempting to connect back - the "Connecting to 127.0.0.1:9100" windows appears, and says configuring remote session, but it just sits there and never goes any furhter.

    We CAN remote in throught direct RDP session - just not through Kaseya. I'm seeing no errors in the agent logs.

    There is no firewall turned on at the server, and there is another server at their location that we connect to fine - so It can't be their firewall appliance.

    We are on version 6.1 and their agent is up to date. Server is a Windows 2008 64bit HP

    Does anyone have an idea what else I might check?

    Gavin

     

  • We also have one client server that this happens to.  It is a 2003 Terminal Server with 3389 forwarded through the firewall.  We have other clients with this same setup but can RDP within Kaseya to them.  Ive never been able to figure out the difference.

  • What is the primary and secondary check in address for this server?

  • Max, the primary and secondary checkin addresses match all other servers which RDP does work with.

  • The issue you are having is in all similar to something that was happening to us.

    I recently came across two Kaseya KB articles that really made a huge difference on the KLC performance/stability/reliability.

    DISABLE IE SMART SCREEN:

    This made the connection negotiation so much quicker and the window stable and not hanging constantly

    community.kaseya.com/.../my-internet-browser-hangs-when-i-launch-the-klc.aspx

    DELETE KASEYA ACTIVE-X FILES

    This made our connections RDP/VNC more reliable in the sense that it now connects practically all the times and you can disconnect the session and reconnect and it will actually reconnect (one of the most annoying things that was happening to us).

    Follow the instructions on the link bellow but basically in my case I just opened the instructed path on Windows Explorer and trashed any file mentioning Kaseya on the Properties (Version or Signature tabs)

    community.kaseya.com/.../how-to-reload-the-active-x-controls-in-klc-for-a-windows-managed-machine.aspx