Kaseya Community

Kaseya Remote Control and Safari 10.0 / macOS Sierra

This question is not answered

Is anybody else unable to launch Kaseya Remote Control from Safari 10.0? I found that enabling the Develop menu in Safari and changing the User Agent to present as Internet Explorer 11 allowed Remote Control to once again launch.

All Replies

    It is in the patch release notes, for 9.4:


    Kaseya Remote Control


    Fixed an issue with Kaseya Remote Control repeatedly prompting the user to download the KRC app when logged into the VSA using the Safari 10 browser on a MacOS Sierra machine.

    I think it was queued up for a 9.3 patch, but I am not sure if it shipped out or the status - I will look into it and get back on this thread.

    I have both 9.3 and 9.4 systems but I am not running sierra just yet on my machine.

  • still not fixed in 9.3 as of patch

  • Thanks very much.

    It did seem to help, however, I tried this trick too but it breaks pop-ups eg in Ticketing when you try and connect a ticket to a machine/org it pops up a window which connects with a new User Agent, then Kaseya logs you out.