Kaseya Community

Unable to disable or configure Windows Auto Update on some Windows 10 machines.

This question is not answered

I have a dozen or so Rapid Recovery cores running on top of Windows 10. They are all more or less identical in configuration. A handfull of these, even after the initial patch scan, will not let me do anything with Windows Auto Update. Most of them return with "Automatic update not supported." A couple of them display the current automatic update setting, but there's no checkbox for me to select that machine to make changes. Here's the screen.

Anyone else here experience this issue, and possibly know a direction to go with it?

All Replies
  • Hi - we know of the same issue and experience it on very normal, average machines.

    Even seemingly identical machines will be split, one will work, the other won't.

    We started a ticket 7 months ago, but never got a resonse past the point of Kaseya acknowledging there was an issue and they told me they were working with Microsoft to resolve it.

    Then the new Software Management tool was announced and  the ticket was updated, this should solve the issue. We recently upgraded to 9.4 and will be testing the module within the next few weeks. Will try to remember to update this ticket when I know more....

    Regards, Eric.

  • Windows 10 software updates install on your system automatically. Here are the steps to follow for disable windowns auto update:

    Open the Run command (Win + R), type - services.msc and press enter

    From the Services list which appears find the Windows Update service and open it

    In ‘Startup Type’ (under the ‘General’ tab) change it to ‘Disabled’

    Restart your system.

  • This doesn't work with Windows 10. Updates still get installed as the service will eventually get toggled back to enabled. Microsoft has confirmed this behavior numerous times.