Kaseya Community

Missing KB4011042 (Outlook 2010 "fix")

  • Microsoft issued KB4011042 on July 5th, but it's not listed in the Patch Management module.  This is the Outlook 2010 fix for the bugs cause by the June Microsoft update.  I'd like to push it out to my users over the weekend.  Will it be added shortly?  Or can I manually add it?  I'm using hosted Kaseya.

    -- Jonathan



    Added note that I'm using hosted Kaseya, not on prem.
    [edited by: JMargulies at 9:48 AM (GMT -7) on Jul 7, 2017]
  • Hello JMargulies,

    As far I know Kaseya get the results directly from the MS Servers they don't approve patches.  I think this update still needs to me aprove to the MS Caltelog:

    This is what I find on Technet:

    Not all updates are published to WU/MU/WSUS

    Some update packages are only ever published to MS Download Centre.

    Some update packages are only ever published as hotfix-by-request.

    In general, if I can't find a specific update by it's KBnumber in the MUcatalog.

    If you want the Patch to install do it directly through Agent Procedure but always test it first ;)

    - Pieter

  • Thanks, Pieter.  I searched the Microsoft Update catalog, but did not find kb4011042 listed.

    I have the patch downloaded to a network share, but I'm not knowledgeable enough with Kaseya to write an Agent Procedure that would copy it to a folder on the local machine and then run the installation.  Is there a sample or similar procedure somewhere that I could copy from?

  • As I understand it, KB4011042 was pulled shortly after Microsoft released it because it was crashing 32-bit Outlook.

    www.computerworld.com/.../microsoft-releases-15-office-patches-for-july-but-some-june-bugs-still-stink.html

  • Sorry, I confused two patches.  The patch that was pulled for crashing 32-bit Outlook was KB3015545.

    -Michael

  • @JMargulies

    Here is an example i did not test is but this would be a kind of Agent Procedure:

    We use this something to deploy Software or Other Packages. I Marked the data out so you need to adjust the information.

    --Pieter

  • Thank you!  You are a gentleman and a scholar.

    However, I'm running into trouble with the second line.  My procedure keeps failing on the second line (GetVariable).  I'm looking for whether the uninstall key exists.  Here's the exact error:

    FAILED in processing THEN step 1, Get Variable, with error Registry Query Failed, Registry Value = HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{90140000-001A-0409-0000-0000000FF1CE}_Office14.PROPLUSR_{C670FB06-D31B-4671-A3EB-946499B6EA0A} (Line 2)

  • No problem. Does the value exist? Otherwise you will get an error. It's only a failsafe to check before just installing the patch. I don't know if you can check for that update in register.

  • I tried to check if exists, but got an error.

    I tried another version of the procedure after I removed the check entirely.  This one failed to find the file I'm trying to copy.  Because I'm using hosted Kaseya rather than onsite, it looks like it's trying to check the hosted server, rather than a server on my LAN.  Is there a way to change this?

    Here's the error:

    FAILED to create IF step, Write File. Error = File not found, Source = D:\Kaseya\WebPages\ManagedFiles\\MyServer\public\kb4011042.exe (Line 4)

  • JMargulies,

    Can you not upload a file to the VSA and use it in an Agent Procedure? Otherwise maybe use GetFile from a source and then try to copy it to Agent Directory (Out of the box thinking)

    Here some information about file distribution: help.kaseya.com/.../index.htm

  • Thank you for that link.  I've tried uploading the patch to both my "Private" and "Public" folders on the VSA, but it fails every time.  Is there a size limit?  The patch is about 85 Meg.  I think I'm just going to open a ticket with tech support.