Hello...

Every now and then (effectively more often that I would like), I get in the Agent Procedure Logs the following line:

[Date]      WUA Patch Scan 2     [Admin]
Processing patch scan results for [this machine] failed.

Note: this is apparently not a writeProcedureLogEntry step in the " WUA Patch Scan 2 " procedure because I've seen this also with " WUA Alternate Patch Scan 2 ".
Now I've noticed that every time I get this line on a machine, you can be sure that the Patch Installation I scheduled earlier (with reboot sometime overnight) is showing all the selected patches as "Pending Installation".

Below is an example:

Machine reboot time

Machine ID server.production.myClient
Group ID myClient.production
Last Reboot Time 8:26:01 am 10-May-13

Agent Logs (Configuration Changes)

12:16:10 pm 10-May-13 Admin FrancisG scheduled scans for missing patches to run at the current time.
4:17:01 pm 9-May-13 Started processing Automatic Update
4:17:01 pm 9-May-13 Patch installation scripts have been generated for 21 patches (*System*).
4:16:49 pm 9-May-13 Admin FrancisG scheduled Automatic Updates for missing patches

Agent Logs (Agent Procedure Logs)

12:16:48 pm 10-May-13 WUA Patch Scan 2 *System*
Processing patch scan results for server.production.myClient failed.
12:16:48 pm 10-May-13 Execute Patch Scan FrancisG
Script Summary: Success THEN
12:16:48 pm 10-May-13 WUA Patch Scan 1 FrancisG
Script Summary: Success THEN
12:16:48 pm 10-May-13 WUA Patch Scan 2 FrancisG
Script Summary: Success THEN
12:16:23 pm 10-May-13 WUA Patch Scan Check FrancisG
Script Summary: Success THEN
12:16:23 pm 10-May-13 WUA Patch Scan PreReq2 FrancisG
Script Summary: Success ELSE
12:16:23 pm 10-May-13 WUA Patch Scan PreReq1 FrancisG
Script Summary: Success ELSE
12:16:15 pm 10-May-13 Run Now - Patch Scan FrancisG
Script Summary: Success THEN
12:16:15 pm 10-May-13 Patch Scan FrancisG
Script Summary: Success THEN
12:16:15 pm 10-May-13 Patch Required Services Check FrancisG
Script Summary: Success THEN
12:16:15 pm 10-May-13 Patch Post-Services Check Action FrancisG
Script Summary: Success THEN
12:16:15 pm 10-May-13 Patch Post-Services Check Action FrancisG
Script Execute Patch Scan was successfully scheduled to run on 190896383585333 in 0 minutes

(...)

4:52:36 pm 9-May-13 Patch Rescan *System*
Script Patch Scan Redirect was successfully scheduled to run on 190896383585333 in 10 minutes
4:52:01 pm 9-May-13 $post$auto$server.production.myClient *System*
Script Summary: Success THEN
4:52:01 pm 9-May-13 Patch Mgmt Svr After *System*
Script Summary: Success THEN
4:52:01 pm 9-May-13 Patch Mgmt Svr After *System*
Server Patch Management: Installation End
4:51:59 pm 9-May-13 Patch Mgmt Svr After *System*
Script Restart Backup Exec Services was successfully scheduled to run on 190896383585333 in 39 minutes
4:51:31 pm 9-May-13 $inst$ptc0$server.production.myClient *System*
Script Summary: Success THEN
4:51:31 pm 9-May-13 $inst$ptc0$server.production.myClient *System*
Script Patch Rescan was successfully scheduled to run on 190896383585333 in 1 minutes
4:51:31 pm 9-May-13 $inst$ptc0$server.production.myClient *System*
Script $post$auto$server.production.myClient was successfully scheduled to run on 190896383585333 in 0 minutes

You can see from the date and times above...

The Patch installations completed at 4:52:01 pm 9-May-13
The Reboot was performed at 8:26:01 am 10-May-13 (someone onsite...)
The following Patch Scan happened at 12:16:10 pm 10-May-13

At the moment, this machine is still showing all 21 patches "Pending Installation"

Here is what I'm after:

Why is this happening ?
What can I do to remediate ?

Thanks

Francis Germain