Kaseya Community

Anyone elses patch scans failing?

  • I've submitted a ticket to Kaseya already, but as of 11/5/1009, over 95% of our installed base are reporting failed patch scans with the following error:

    WUA Patch Scan PreReq2
    "FAILED in processing THEN step 4, Execute File, with error Invalid executable file, C:\temp\WindowsUpdateAgent30-x86.exe /quiet /norestart"

    Manually checking that file shows it to only be 4KB in size which is obviously incorrect. Manually deleting and rerunning patch scans results in same error.

    Anyone else seeing the same thing?

    EDIT

    We've solved our problem ourselves. After checking the VSA Server, we found the Windows Update agent files that were located at "C:\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles" were corrupt.

    We manually downloaded those files and put them in the above folder, patch scans are working again.

    Legacy Forum Name: Anyone elses patch scans failing?,
    Legacy Posted By Username: eruberts@sjconsultant.com
  • I would just like to add that the above solution also worked for us running K2.

    The WindowsUpdateAgent30-x86.exe and -x64.exe on our Kaseya server where both 32Kb in size and produced the agent log entry:

    ERROR: execFile() will not run c:\kworking\WindowsUpdateAgent30-x86.exe because it is not a valid executable.

    After replacing the two .exe files on our Kaseya server with thos downloaded directly from Microsoft (which are 6 and 7 Mb in size) the update scan now works as expected.

    Legacy Forum Name: Patch Management,
    Legacy Posted By Username: nathane
  • Based on this and other threads, it seems to me that Kaseya's code that handles file transfers does little, if any, verification that the source file being copied matches the destination file. I am surprised though, as one would think a simple CRC or hash check would catch all these corruption issues.

    Legacy Forum Name: Patch Management,
    Legacy Posted By Username: ReedMikel