Kaseya Community

VSA - Patch Management - Windows Automatic Update

  • So what is patch 9.5.0.15 supposed to do for this?  I show systems with the "Windows Automatic Update Configuration" set to "Automatic Update not supported." after installing it.

    Just checked that system for the registry key(below) and it is there.  System is Win 10 1709 - shows "...not supported"

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoUpdate DWORD 1.  



    Follow up on system with symptom
    [edited by: Tim Varvais at 8:09 AM (GMT -7) on Oct 12, 2018]
  • The 9.5.0.15 'fix' is just a more consistent disabling of the ability to control automatic updates through Kaseya.

    Kaseya's misunderstanding of Windows 10 patching would be comical if it weren't such a serious matter for us, their customers.

    We just set the registry key above (same as described in my earlier post) and move on with our lives, haven't got the time or patience to argue with Kaseya about it.

  • I have just started coming across this as most of our devices were on 1709 and have recently began to implement 1803.  We have our GPO set to disable automatic updates and I can see that configured in the machine settings under view configured update policies.  

    Would the reg key weekly script be the best approach to resolve this?

    I have come across recent feature update failures and now understand that the machine is updating separately from the Kaseya patching.

    I would expect that by now we would have a better solution but I have not found one yet to reduce the feature and roll up automatic updates and only manage all updates via Kaseya.

  • Combo- Would you be able to share more information about how you are automating the feature updates in a silent manner?  We have just started having some issues with machines attempting to pull feature updates, they fail and Kaseya scheduled updates not running.  It seems that as the upgrades and other windows managed updates queue up and fail, Kaseya scheduled updates will continually stay in a pending state.  If I can do something to automate and force this, perhaps I can resolve the issue.