Kaseya Community

Update missing from kaseya

  • My understanding is that the patches for XP/2003/8 won't be made available via Windows Update, so Kaseya's automated process to parse the metadata and add the patches into the VSA won't happen.

    I suspect manually installing is your best bet. The nice folks at Upstream have already written agent procedures you can use for this - upstream.se/.../upstream-power-pack

  • ,  take a look at this blog post I did about MS17-10.   In there I did a quick video on how to create the report to look for the results.   virtualadministrator.com/.../using-kaseya-to-audit-for-ms17-10-to-prevent-wannacrypt-infection

  • Was anyone else able to set up the view provided by ?  I am getting a 'The multi-part identifier "psw.MKB.kbArticleID" could not be bound" error when I try to save.

  • In my environment (9.3 still), if you look at the view "before" the modification it was pswMKB.kbArticleID so I had to drop the . from between psw.MKB.   After that it was simply a matter of getting all of the parenthesis in the right spots :)

  • Thanks Jonathan.  That did it.

  • Guys,

    Tonight I was playing around with the powerpack script for XP. I could not get it to work correctly.

    It would download the exe but it does not run.

    I watch it execute on the endpoint from task manager and it shows up for a few seconds and goes away.

    If i run the file manually, it does install successfully.

    So this is what i find out:

    The EXE needs to extract files out into a directory and then run the Update.exe file that actually runs the update on the XP machine. The Update.exe part never runs.. So after doing some google research, i was able to extract the exe we were pulling down from the MS site. Once extracted, I was able to run the update command from executeshell command and the patch got applied. I was able to see the update.exe process run for a few minutes to complete via task manager Once it completed, i rebooted the machine and the patch appeared in add/remove programs.

    just wondering if anyone else had any luck with this script.

    can you shed some light on this script?

  • Hi ,

    I had a similiar issue. I changed the execute shell command that runs the patch so that it runs as system and changed the reboot switch from noreboot to norestart and it worked fine for me following that.

  • Thanks for the feedback guys @JB1975 @Buster Davis.

    Man, this week have been insane. A lot of meetings with MSP's regarding Patch Policy compliance, go figure. Finally I have got the time to corrected this in our XP Wannacry procedure. We have adjusted to run as system and changed to /norestart as JB1975 suggest and found working. Just download again if you want the corrected version.

    en.upstream.se/.../upstream-power-pack

    Normally we test our procedures back and forth at least a week on supported OS's before releasing it to Upstream Kaseya Power Pack, but this one had to come out the door quick. Just about one hour in the making. Didn't even have a decent XP to test on. We really appreciate the feedback we get from all of you. This makes our content stronger and better suited for all of you out there.

    Kind regards. Ronny Tunfjord, Head developer of Upstream Kaseya Power Pack.



    spellcheck
    [edited by: Ronny Tunfjord at 4:13 AM (GMT -7) on May 19, 2017]
  • Hi all - you may be interested in this thread.

    community.kaseya.com/.../105496.aspx