Kaseya Community

MS11-025 Failures

This question is not answered

Is anyone else having problems with patch MS11-025, Security Update for Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package? It failed on every machine I tried to deploy it to and took about 2 hours on each before the patch process moved on to the next patch.  On one machine that I tried during the day, I got an error pop up with the message "Command line option syntax error.  Type Command /? for Help."  The other machines patched overnight, so I am not sure if the same message appeared.


All Replies
  • That issue should be resolved shortly.  If you would like to manually correct the issue to deploy the patches sooner, follow these steps:

    • Navigate to Patch management > Command Line

    • Select the affected patches (there may be multiple with the same KB#; select all entries for the listed KB#s with incorrect switch setting)

    • Enter the following into the New Switches field at the top of the Patch Management > Command Line page:  /q /r:n

    • Click Apply

    • The patches should now install successfully

    Do NOT change switches for patches when you are unsure what the switches should be.  Each patch may support different switches, so while /quiet /norestart is valid for some patches, others may require /q /r:n or another set of switches altogether.  If you are not sure what needs to be done, please contact Kaseya Support for assistance.

  • I'm also having this issue and saw the same error message today on a client's console, have tried to apply the recommended action above but the KB entry doesn't seem to appear on my Kaseya Console in the location you suggest.

    Patch KB2467174/MS11-025

    Patch KB2467175/MS11-025

    The above two entries are also seen for the same machine, different KB# but same MS#

  • Both of these KBs were updated last week and should reflect with the proper switches after a rescan of a machine reporting the patch.  If the switches are still incorrect, identify a machine that "needs" the patch and run Patch Scan on the machine.  The switches should update.

  • Still have system(s) that are reporting this error, although the number is slowly diminishing.

    Have patch scan scheduled for daily so this issue should have disappeared two days ago now shouldn't it?

  • Still getting the same problem on all servers managed by Kaseya, can see in command line that the switches have updated to what is mentioned above. Are we alone? Is there something else we can do?

    [edited by: ITCPL at 6:51 AM (GMT -7) on 6-1-2011] edit notes
  • www.microsoft.com/.../details.aspx shows three different files for this patch

    32 bit IA64 and x64. Im wondering if Kaseya is grabbing the wrong one..

  • Two months later, I am still getting this error on the most recent version of this patch.  Am I the only one?

  • No defiantly not the only one! It's extremely annoying!

  • Every single patch failure alert currently on my board includes MS11-025 as a failure..

  • There is also no immediate pattern to these fails, some are workstation (XP thru Win7) others are server from 2k3 thru 2k8R2

  • Has Kaseya fixed this? I've just had two customers with the same problem this afternoon?

  • I have also noticed this issue, have not had time to get to it yet so hopefully it gets fixed before I do or I will try Brande's solution.

  • I have found this problem too.  I am re-running the patch scan and try again to see if it is fixed.

  • Im currently seeing this issue on multiple O/Ses from workstations to servers.

    KB2538242/MS11-025 fails on 15 machines

    KB2538243/MS11-025 fails on 5 machines

    No pattern visible as yet.

  • /quiet /norestart is giving that syntax error.

    Brande's solution (listed above) will install the patches, *however* it does not do it silently. There are pop-ups when the installer is processing. At least that is my experience on several XP machines.

    The following script uses the same switches that Brande mentions above. For whatever reason, it will process the patch silently even though it is seemingly using the same commands. Tested on XP only so far. Upload the appropriate file to your kserver.

    <ScriptExport xmlns:xsi="www.w3.org/.../XMLSchema-instance" xmlns:xsd="www.w3.org/.../XMLSchema" xmlns="www.kaseya.com/.../Scripting">

    <Procedure name="Sec Update VS 2005 SP1" treePres="3" id="1584098004">

    <Body description="KB2538242 - Critical Security Update">

    <If description="KB973923 - Critical Security Update">

     <Condition name="True" />


    <Statement description="" name="GetVariable" continueOnFail="false">

     <Parameter xsi:type="EnumParameter" name="VariableType" value="AgentInstallDrive" />

     <Parameter xsi:type="StringParameter" name="SourceContent" value="" />

     <Parameter xsi:type="StringParameter" name="VariableName" value="agentDrv" />


    <Statement description="" name="WriteFile" continueOnFail="false">

     <Parameter xsi:type="StringParameter" name="Path" value="#agentDrv#temp\X86-all-vcredist_x86.exe" />

     <Parameter xsi:type="StringParameter" name="ManagedFile" value="VSASharedFiles\MSUpdates\2011\X86-all-vcredist_x86.exe" />

     <Parameter xsi:type="BooleanParameter" name="DeleteAfter" value="False" />


    <Statement description="" name="ExecuteFile" continueOnFail="false">

     <Parameter xsi:type="StringParameter" name="Path" value="#agentDrv#temp\X86-all-vcredist_x86.exe" />

     <Parameter xsi:type="StringParameter" name="Arguments" value="/q /r:n" />

     <Parameter xsi:type="EnumParameter" name="ExecuteAccount" value="System" />

     <Parameter xsi:type="BooleanParameter" name="WaitComplete" value="True" />


    <Statement description="" name="ExecuteScript" continueOnFail="true">

     <Parameter xsi:type="StringParameter" name="ScriptID" value="269" />

     <Parameter xsi:type="StringParameter" name="ScriptName" value="Patch Scan" />

     <Parameter xsi:type="StringParameter" name="TimeDelay" value="5" />

     <Parameter xsi:type="EnumParameter" name="TimeUnit" value="Minutes" />