Kaseya Community

Backup Exec Checking Scripts

  • Howdy,

    I'm working with the backup monitoring scripts that are in the recent Kaseya script pack, however the v10 versions are misbehaving. The first few steps complete fine, it schedules script four for one minute time then that fails with "Failed ELSE in step 2"

    The script log is as follows:

    23:34:53 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 4-4 adrian
    Script Summary: Failed ELSE in step 2
    23:34:53 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 4-4 adrian
    FAILED to create ELSE step 2, Execute DOS Command. Error = Script variable is undefined. It must be defined by a GetVariable step earlier in this script or a parent script., No command specified
    23:34:53 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 4-4 adrian
    All Jobs completed with or without exceptions
    23:33:51 10-Sep-09 Run Now - BackupExec JobStatus Check (BEMCMD) 1-4 adrian
    Script Summary: Success THEN
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 1-4 adrian
    Script Summary: Success THEN
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 2-4 adrian
    Script Summary: Success THEN
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 3-4 adrian
    Script Summary: Success THEN
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 3-4 adrian
    Script BackupExec JobStatus Check (BEMCMD) 4-4 was successfully scheduled to run on 49911458304753322464518064 in 1 minutes
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCDM) upload 1-2 adrian
    Script Summary: Success THEN
    23:33:51 10-Sep-09 BackupExec JobStatus Check (BEMCDM) upload 2-2 adrian
    Script Summary: Success ELSE
    23:33:47 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 2-4 adrian
    Yes, it is a Thursday now. So a backup check should be performed.
    23:33:25 10-Sep-09 BackupExec JobStatus Check (BEMCMD) 1-4 adrian
    Admin adrian scheduled script BackupExec JobStatus Check (BEMCMD) 1-4 to run at 23:33:25 10-Sep-09 one time.

    The ELSE in Step 2 is as follows:

    Execute Shell Command
    echo Completed >> #AgentTemp#\BEC\FilePreFix.txt

    The 'AgentTemp' is defined in the first script, so I can't see why it's failing.

    Can anyone make any suggestions please?

    Regards, Ade.

    Legacy Forum Name: Backup Exec Checking Scripts,
    Legacy Posted By Username: PuffinRub
  • Hey try this


    download link



    http://rapidshare.com/files/283885222/Backup.txt.html

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: gopinath.jayakumar
  • @gopinath.jayakumar... Nice work, just copy and paste the contents of the txt file into the "Import Folder" link...

    But... where are the .VBS files?

    EDIT: @PuffinRub... I've found that sometimes the variables don't pass from script to script for some reason. I've used the define variable route a lot and have just started going to the predefined variable #vAgentConfiguration.AgentTempDir# because of this.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: thirteentwenty
  • The file has been removed, anyone still got a copy of this info please?

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: stu_u2k