Kaseya Community

K Agent Update Done Script

  • I found on one of my agents that the system script "K Agent Update Done" is spamming the script log, looks to be running every minute.

    Legacy Forum Name: K Agent Update Done Script,
    Legacy Posted By Username: cnwicsurrett
  • k-agent-update-done-01.JPG
    Ditto. I started noticing this as a result of machines that had outdated agents on them. Some of the machines didn't have the agentmon.exe path so I created a script to add that registry key back in and then updated the agents again. Now while some of the agents took it just fine the remaining ones continue to spam the logs with K Agent Update Done messages but do not actually update. I've found that if i reboot the machines The spam stops but the agents still don't reboot. Attached are some screenshots of a machine i've been updating/rebooting to get the data from. Any help would be both really swell and appreciated. Big Smile

    ***EDIT***
    After uploading the 4th screenshot and looking at it, i'm beginning to think it is a filesystem permissions issue as well as possibly an agent temp directory issue. Looking deeper.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: tsorensen@group1auto.com
  • k-agent-update-done-03.JPG
    Attachment refers to previous post.

    Legacy Forum Name: ,
    Legacy Posted By Username: tsorensen@group1auto.com
  • k-agent-update-done-02.JPG
    Attachment refers to previous post.

    Legacy Forum Name: ,
    Legacy Posted By Username: tsorensen@group1auto.com
  • k-agent-update-done-04.JPG
    Attachment refers to previous post.

    Legacy Forum Name: ,
    Legacy Posted By Username: tsorensen@group1auto.com
  • Just from what I see in those screenshots I'd agree with your theory of permissions issue on the temp directory. Let us know how it goes.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: kroberts210