Kaseya Community

IF "User is Logged in" fails

  • K Version 4.8
    This isn't a script problem but a function of Kaseya Agent?
    For sometime now we have had scripts failing because we check to see if the user is logged in before executing the script and recalling the script in the else. Here is the problem, K reports that there is no user logged however there is a user logged in. A workaround we used is to send an email to myself in the else and manually install or verify the user is logged in and rerun the script with the If set to True.

    Has anyone else experienced this?

    Legacy Forum Name: IF "User is Logged in" fails,
    Legacy Posted By Username: termv
  • Encountered same problem today. Ran a script against a user's machine only to get a phone call from the user asking what was going on. Per kserver, the user was not logged in. User was on an XP SP2 machine.

    Havent seen this happen since Kaseya SP1. Wonder if something in SP1 made this occur...

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: mariaworld
  • I'm seeing this in K2008, without SP1 being installed. Not often, but it has happened.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: Lmhansen
  • We see the same thing. I noticed it prior to SP1 also.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: techsquad
  • I've seen it on my own personal workstation, which is running Vista SP1. I have Kaseya 2008 SP1 installed, and sometimes the agent just seems to hang, even though it still runs scheduled tasks like it should. I can't right click on it and select Refresh, and it shows no user logged in when looking at it in the server console. A reboot alway fixes it, but it seems to come back after a while.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: kcears
  • Re-executing this exe should set things right without requiring a reboot:
    C:\Program Files\Kaseya\Agent\KaUsrTsk.exe

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: mariaworld
  • mariaworld
    Re-executing this exe should set things right without requiring a reboot:
    C:\Program Files\Kaseya\Agent\KaUsrTsk.exe


    Re-executing not always in effect.Confused\

    BTW:Its shows in missing the K icon sometimes.
    Entironment:VMware Server 1.0.2 build-39867, Windows Server 2003 Enterprise Edition Service Pack 2 Build 3790

    Sorry for my bad EnglishSad

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: aaron@cccc.us