Kaseya Community

User Logon Prompt

  • LogonPrompt.zip
    The following scripts will set the user logon prompt. This will allow for a little morevisability of your managed services on the user desktop. In addition to providing a phone number right on the screen if they can't login.. You may have to add or remove spaces in the vbs script to center the two lineson the login box.


    Legacy Forum Name: User Logon Prompt,
    Legacy Posted By Username: cberger
  • Big Smileude:ANOTHER GREAT SCRIPTED THANKS!!!!!

    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: itopsr
  • Imported Empty Post

    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: cberger
  • The script works if I execute it from the command line, but if I use kaseya to run it, it hangs up for a long time. No other scripts can execute.

    Any ideas?


    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: rvines
  • I'm just guessing here but it may be a User mode v.s. System mode issue. Notice "Parameter 3 : 3" in the Execute File commands. This indicates "Execute as system and wait for completion". The script is executing as the system rather than a user. If the script is sitting there waiting for a user response, it will wait until the script times out (2 hours) before continuing because there is no user interface when running as the system.

    A lot of anti-virus programs block or prompt before letting wscript run anything. The script might be sitting there waiting on a problem like that. Try changing changing step 2 and 3 to "Execute as user and wait for completion" to see if that works. Note that a user with admin rights must be logged logged in or the VB script won't get access to HK_LocalMachine in the registry. You could also try adding a Use Credential command to the beginning of the script and set an admin credential for that machine ID


    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: Mark Sutherland
  • I noticed that some characters were removed when I cut and pasted into the forums which probably caused that issue.. I attached the scripts in a zip file to the original post.

    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: cberger
  • I had corrected the missing characters in my script, but it still hangs.

    Here is the export of my script:

    Script Name: Set Login Prompt
    Script Description: This script will set the login prompt.

    IF True
    THEN
    Write File
    Parameter 1 : c:\temp\LogonPrompt.vbs
    Parameter 2 : VSASharedFiles.logonprompt.vbs
    OS Type : 0
    Execute File
    Parameter 1 : %windir%\system32\wscript.exe
    Parameter 2 : c\:temp\LogonPrompt.vbs
    Parameter 3 : 3
    OS Type : 1
    Execute File
    Parameter 1 : %windir%\wscript.exe
    Parameter 2 : c:\temp\LogonPrompt.vbs
    Parameter 3 : 3
    OS Type : 2
    Delete File
    Parameter 1 : c:\temp\LogonPrompt.vbs
    OS Type : 0
    ELSE

    If I run wscript c:\temp\logonprompt.vbs on the workstation, it has no problem




    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: rvines
  • This maybe anissue with slashs and this forum, but the path in your step 2 below appears incorrect. With the incorrect path to the vbs file,it would present a pop-uperror dialog box that would require a user to press or the kscript would hang. I also agree with Mark below, some Antivirus and/or AntiSpyware blocks execution of some scripts. But considering it works from commandline, it's probably not the vb script. Try substituting the LogonPrompt.vbs with another vbs script and see if you get the hang. I downloaded the zip file and tested it again with no issues.. Let me know it goes..

    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: cberger
  • Reloaded from your zip file and now it works!

    Thanks!


    Legacy Forum Name: System Administration Scripts,
    Legacy Posted By Username: rvines