Kaseya Community

Remote Skype Silent install Script issues

  • Hello all,

    I'm trying to do a silent install of Skype system accost all of my network PC's and I'm having some issues. I've run through a few things and each time nothing seems to happen. The script is setup to basically give the agent user admin rights to make sure the proper access level is granted then copy the files that I uploaded to install the Skype system over to the PC in my folder. Setup the folder in case it isn't already and do a Silent install in the background. 

    I don't even see the files being written over to the system at all as I jump on the PC and watch the folder to see what happens. Its as if the write-file code doesn't execute and its causing frustration as I really would like to have this remotely deployed rather than touching all the PC's.  Attached is a screen shot of my script and maybe I am to new to this to understand why its not working, but I would love to get some input on this to make sure I can get this done.

    thank you,

  • Hi,

    Your writedirectory command is missing a source location.

    You are currently writing nothing to the machine

  • ,

    You need to define the full file path including the file name when you copy and write the file.  As  mentioned, you're not actually asking the script to write anything (the file itself) to the endpoint.

    In the writeFile step, define the location on the KServer.  In the procedure editor, the fields should look something like this (use the actual location, file name, and destination as appropriate)

    If you don't define the file name (including extension) for both the FROM and TO locations, nothing will write to the endpoint.

    In your execute step, ensure your exact cmd string would work if you ran it on the local machine.  If the cmd step does not produce the expected results when run locally, it will not be successful when executed by the AP.  

  • Thank you both for the update,

    With both of your posts I want to clarify another thing then to make sure my writeDirectory command is proper as well. Looking at that part I didn't see a reson to put a source directory but it seems that these scripts need to be precise in their setup to work and I want to go back through and see if the write needs that area setup if i'm looking to move it to a specific folder as I wanted to: a) make sure the PC has my main directory repository and b) has the sub folder to house my install files

    I've added in a second line to write my sub folder for the install files, but do I need both areas setup like shown above or do I just need the second one and the first one just need the C:\wst - or do I need that first line setup at all?

    Last question is just to verify my write script in conjunction with the added line for the sub folder. see below screenshot to verify proper setup

    I'm trying to study up on proper Kaseya scripting as there is so much I would like to implement into our system, but need to understand the proper way to create everything. Best to start basic and this seemed simple enough to start with. If there is a better area to go to and read up on everything I would do that as well, but thought asking questions in the forums might be best. 

    Thank s again for your help on this. 

  • What you have there is fine and should now work.

    Note that you can write files to any location, as well as rename as part of this.

    The only thing you need to be sure of is that this is the same name/location as the rest of your procedure references.

    If you are unsure about kaseya procedures I recommend writing more of them to do different things and reading the help.

    The main issue when starting to learn is that there are many different ways to accomplish the same thing, as long as it works don't really worry about it.  :-D

    Most of the time you will be writing a file and running it, we use a lot of powershell to do anything meaningful and we action this by writing the ps1 file onto the machine, and then running it from the procedure.

  • Thanks for the help on this. I did try and run this and the script ran the way it should have but ran into a hiccup with the exe/msi files. I have to redesign it a bit since this was set up as a patch file and not a MSI file so a little back tracking.

    I did use Kaseya software deployment to have Kaseya create a silent install for me which was nice since it did transfer the install file but the issue was it never executed the install file at all. I had to log in and run it manually.

    The default script came up with exicute file

    %windir%\system32\msiexec.exe - under that path

    with argument of:

    /i #agentDrv#temp\lyncentry_4351-1001_x64_en-us.exe /q

    Which ran as system and wait.

    I did track the file went to temp which is good, but still didn't do a silent install. I'm going to have to go back to my script and see about adding in a few line items and move over the install file and see if I can clean up the MSI and xml doc to preform the silent install.

    Is there a way to see inside of kaseya if there were errors at all or not? I was thinking maybe the event viewer on the PC, but wasn't sure if Kaseya had a way to track events at all too.

  • So I am trying to troubleshoot the execution on this from the command prompt directly just to verify the script itself locally and I even downloaded a 32 bit installer to see if its just because the PC doesn't have a 64 bit cmd even though it is 64 bit OS> So I then tried to execute from command and I get this. If I open the installed manually and run it there are no issues but when I run from CMD this error pops up.

    I have checked to make sure the exe is not blocked as well and still does the same thing. Event he kaseya silent install doesn't execute so this is the same issue I've been running into and I would appreciate any advise anyone can give me.