Kaseya Community

Procedure to copy file to desktop worked before, now indefinitely hangs

  • Hey guys. I previously made a procedure to copy a shortcut to the public user's desktop folder and it worked before (about 3 months ago) and now when I try to run the same procedure, it never finishes. It can be a scheduled task or a run now task and it never successfully finishes but it doesn't give me an error either.

    Here is the code

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <ScriptExport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://www.kaseya.com/vsa/2008/12/Scripting">
    <Procedure name="MSDS Desktop Shortcut" treePres="3" id="21658602" folderId="549384980159525" treeFullPath="myProcedures - sadmin">
    <Body description="">
    <Statement name="WriteFile" continueOnFail="false">
    <Parameter xsi:type="StringParameter" name="Path" value="C:\Users\Public\Desktop\MSDS-Online.lnk"/>
    <Parameter xsi:type="StringParameter" name="ManagedFile" value="VSASharedFiles\MSDS-Online.lnk"/>
    <Parameter xsi:type="BooleanParameter" name="DeleteAfter" value="False"/>
    </Statement>
    </Body>
    </Procedure>
    </ScriptExport>
  • Hi ,

    Does it the same machine you test ? I've made something like you and worked fine from my side on XP and 7...

    I think you should open a ticket on zendesk...

  • I had an existing ticket for reports not working and eventually all other things started to not work for some reason. I reinstalled the Kaseya server and it seems to be working fine again.