Kaseya Community

Delete registry key step command doesn't work

  • I have a procedure that checks for the existence of a key then deletes it.  I ran the procedure and it claims to have completed with no problems.  Now when I run it again, it says the key is not found, which I would assume to be correct.  However, when I logged into the server and checked the registry manually, I found the key still there and had to delete it manually.  What's the deal?

     



    [edited by: andrewf at 9:02 AM (GMT -7) on May 15, 2013] fix
  • Hi Andrew-

    Here's a wild guess:  By any chance, is this a 64 bit machine?  If so it's possible you are deleting things out of the 32 bit section of HKLM\Software and mean to be deleting them out of the 64bit area using the 64-bit specific script steps.

    -Bill

  • This is a 64 bit machine but I wasn't aware that there was a difference in registry between the two?

  • Look here and see if there is/was the section you wanted to delete...

  • Paste fail...

  • Okay disregard my previous post.  I do see an AppAssure key under the Wow6432Node and it doesn't have the ReplayEPS key underneath that, is that what the procedure deleted?

  • You've got it

  • Thank you!

  • Okay so now I've revised my procedure to delete key using delete 64-bit registry key and this is the error I'm getting:

    FAILED in processing THEN step 1, Delete 64-bit Registry Value, with error Registry Access Failed, HKEY_LOCAL_MACHINE

    I even added Use Agent Credentials to the procedure thinking it was an access issue but doesn't make sense since there was no problem deleting the 32-bit key.

  • Try using the command below in a Execute Shell Command


    REG DELETE HKLM\Software\AppAssure\ReplayEPS



    [edited by: HardKnoX at 8:48 PM (GMT -7) on May 16, 2013] blah