Kaseya Community

Running VBS as a system account

This question is answered

I have two scripts that will only run with the option user logged in and not with the system account. I tried with execute shell command and still same result. Any Suggestions?

Verified Answer
  • Because the SYSTEM account runs in a non-interactive session. In other words, it doesn't have a keyboard :P

All Replies
  • what is the script doing ?

    maybe when run as system it doesn't have access to what ever eg mapped drives ?

  • Script is not accessing mapped drives. It's running a registry cleaner local to the machine.

  • it will be something like that though. add debugging to your app. As in get it to write to a text file where it's upto so you can figure out where it's going wrong . The other normal issue people have running VB is that there is no Start in by default when the script is run

  • If you are running ccleaner (or most likely most registry cleaners) they usually only clean the registry of the logged on user anyway. What one are you using?

  • I'm not running ccleaner I'm running Eusing Registry Cleaner it has command line options. The VB is calling the program from run basically and executing. Why am I doing it this way you ask instead of command shell? because it has annoying pop up in the beginning that asks you to register the freeware, so I wrote a vbscript to hit the enter key.

  • Perhaps you could contact the guys at Eusing to work out some sort of licensing deal so you could use the full version that doesn't have the pop-up?

    Their published pricing is understandably prohibitive for larger scale usage but I bet if you told them what your goals were you could work something out.

    I know it is 'Freeware' and while I haven't looked at their licensing model you're probably not supposed to be automating your way around UI nags.

  • What is it that makes Eusing so much better than, say, ccleaner? Is there a point reinventing this wheel?

  • Well I guess my question is with the SendKeys command in a VBSCRIPT In Kaseya. It doesn't work when running under NT\SYSTEM. Anyone know why?

  • Because the SYSTEM account runs in a non-interactive session. In other words, it doesn't have a keyboard :P

  • Had a feeling about that lol thanks!