Kaseya Community

TreeSize clone script

  • moderator: delete this please

    moderator: delete this please
    [edited by: kuuser at 9:37 AM (GMT -7) on Aug 8, 2014]
  • retrieved the files from the Git... put it on my kaseya server and now they're generating correctly.

  • Any examples on how to do this? Set-ExecutionPolicy RemoteSigned

    I've tried inputting it via Executeshellcommand by itself as well as with the treesizehtml within the procedure with no dice.

  • Does it throw an error?  I first got an error because I put the command in the first parameter of the executePowerShell in the procdedure.  It goes in the second one.  When you're done the first line of the procedure looks like this:

    executePowershell(" ",set-executionpolicy -Scope Process -ExecutionPolicy RemoteSigned", false, "All Operating Systems", "Halt on fail")

  • Im running this powershell script locally on my server. I just cant get it to work. Could anyone point me in the right direction ? Like what do i have to do with the files Kuuser uploaded ?

  • There is a nice little util to map out drive usage. Anyone have such a thing in a script?


  • Procedure Audit C drive size and usage and email results to support.xml

    The files I uploaded were just the missing javascript and images and css.  I followed the directions at the beginning to install it.  

    I use another script that emails us the largest directories/files in a tree (that particular script doesn't tell you free space left if I remember correctly).  It was included in the procedure pack from Kaseya.  I'll upload it here. You can copy it and change the drive letters.  You'll also sfk.exe from here: http://stahlworks.com/dev/swiss-file-knife.html

  • Hello James

    I have implemented same exact agent procedure and PS1 file but I am not getting the zip file. I also try to run some example command you provided in powershell like -paths "C:\" -reportOutputFolder "C:\temp" -htmlOutputFilenames "c_drive.html" –zipOutputFilename "report.zip", Also it is not working as well. I am using power-shell 4.0 and I downgrade it to 2.0 with command prompt since I found this code is working with 2.0.

    I am not getting any error but the code is not working for me.

    Thanks in advance


  • when I run the agent procedure or ps1 file with example provided in ps1 document, I cant find any zip file at all? any suggestion or help

  • Has anyone gotten this to work recently?

    I am highly interested in this