Kaseya Community

+++SQLCMD broken in Agent Procedures

  • Am I going mad or has using +++SQLCMD in a Get Variable step being further limited.

    It used to work fine as long as there was a space at the begining of the string i.e. " +++SQLCMD:SELECT ........ etc "

    Then it broke and I found that if you wrap the entire script in an "If Always True" Step we were able to export and import them again

    Now is just doesn't seem to work at all

    Am I alone in this or are others now facing the same issue ?

    It seems the only way around this now is to put some bogus string in as the variable , then go into SQL and edit the scriptThenElse table and paste in the actual +++SQLCMD into the teFuncParam2 field

     

  • Wait for it......

  • Aye ? Wait for what ?

    Paul

  • Don't use it through the get variable but do use it as part of a shell command and it works OK for me.

  • Yeah they said that they where going to disable this functionality but I'm smarter! DevilCool

    The only problem now is I don't want to share how I got around it as if I do they will lock it down again and I will have to waste more time finding another workaround.Zip it!

    So to Team Kaseya I say stop removing valuable functionality and waste our time!!! Super AngryAngry

  • Cheers .. but could you share the latest trick privately by sending it to my email address

    Cheers

    Paul