Kaseya Community

Installing Mac PKG - GRRR

  • OK So I am trying to deploy ESET.pkg using kasya.

     

     

    The bit that is failing is this...

     

    Run Shell Command: installer -pkg /tmp/eset.pg -targe LocalSystem

    [Run as System Account]

     

    It fails wont install yet if I remote onto the Mac and run sudo installer -pkg /tmp/eset.pg -targe LocalSystem

     

    The PKG gets installed perfectly.

     

    What is going on please

  • Have you tried the custom procedure step to install a PKG on OS X?

  • Yes and Kaseya says it was successful yet it wasn't. Hence why I tried to manually run a shell command.

    Another note is that installing requires ROOT access so I presume kaseya has this elevated access when the [Run as System Account] is checked?

  • Our service runs with root-equivalent access. Is this Eset package something that can be downloaded from the Eset website or is it something you could share with me directly in an email?

  • Sure let me know where to send it or I can add it to my dropbox as its 47MB