Kaseya Community

Disable Windows Security Center

This question is not answered

Hello Kaseya-Experts.

Searching for a solution to disable the annoying windows security center-messages. Customers calls and a few minutes later KAV is updated - hm... call for ... 

I've found only one solution: http://community.kaseya.com/xsp/f/28/p/6345/30450.aspx

Have anybody a up-to-date procedure? for Windows XP to Windows 7?

 

 

 

All Replies
  • Here are a couple of links that might get you going:

    http://thebackroomtech.com/2007/10/04/howto-disable-windows-security-center-nag-screens-via-the-registry/

    http://www.ehow.com/how_6835513_disable-windows-security-center-registry.html

  • this only partly works on Windows 7 :( If the user manually opens the security centre it still shows the 'issues'. Anyone taken this any further?

  • I know of two "hacks" and neither one is pretty. There is a certain DLL we can un-register to kill it outright, but I can't say I recommend doing that. The other method involves a VBScript that loops through all the user profiles on a computer and kills it in the registry. Even then a re-log is required (or close explorer.exe and re-open...) before it will take effect.

    Let me take a step back for a second though. Perhaps the Action/Security Center isn't as bad as everyone makes it out to be? I personally don't think it's a bad thing when a user calls in letting us know their virus definitions are out of date. Not to mention it often gives the user a solution for self-healing and then they don't even have to call. Just my two cents.

  • My personal opinion is that users should be doing user stuff and that shouldn't involve spending their "at work" time working on the computer or systems themselves. They should be selling or financialing or managing or whatever else it is that they do and it's up to me and the crew to see that their systems and software are clean, current, and functioning correctly.

  • I know this isn't super-helpful, but there's an option in the KDPM module to disable Action Center ... To be honest, I haven't used it - but it's definitely there. :P

    Update: OK, now I have used it (Win 7 x86.) Required a reboot, but now the Action Center is completely gone. Will test on XP if I get a chance. Not a procedure, but it's something...!



    [edited by: Kerry D at 12:21 PM (GMT -7) on 5-15-2012] Updated after local testing
  • Easiest way is to disable the security center. Just execute command "sc config wscsvc start= disabled", and the security center will not start up on the next reboot.

    Unfortunately, with Windows7, the Action Center may complain that the Security Center is off ...

  • Procedure Disable Security-Action Center Notifications.xml

    Here is a procedure that should do the trick for you.

    Does take a reboot to kick it into gear.