Hi All,

I really need some help on this, I am trying to create a script to install the latest version of Adobe Flash Player.  I found some goo dlooking scripts on teh forum and tried to use them but they failed so I have spent the last 2 days creating my own and getting them working.  This is my first foray into teh work of procedures and so far it has been frustrating.  I created a simple script to check if the file was located at the central location and download it if required, it then makes the logged in user admin for 5 minutes and runs the installer from a central file share location that everyone has full access to.  This works fine on windows server OS and Windows 7, it fails on XP.

I have now created a simple procedure that runs a batch file, all the batch file does is call the installer via the executre command shell option.  If I log into the workstation and run the batch file it works.  If I run it as a procedure from Kaseya the log in Kaseya says it was successful but the package is not installed. 

 

I have tried getting Kaseya to run the batch file locally and that works but from a file share it fails, I have then tried to copy the file from a share to local but that also does not work but if I do that out of Kaseya (logge din locally to workstations) again it works.  I cannot see any reason for the install not to run via Kaseya, I have disabled all firewall’s and AV products.

 

Please help, I do not understand why it will not work via Kaseya for XP and I have no idea how to work out why either, the standard debugs are showing nothing and when I ask kaseya how to further debug this I do not really get an answer.

Please remember that in the same network running the same procedure on windows 7 works fine.