Kaseya Community

How to overcome Windows prompting for executing a exe/msi to install apps ?

This question is not answered

This should be such a basic/easy thing since every installer has to overcome it, but every script we write to install anything fails (well actually it just never completes and we have to cancel it) because if we try to run say \\installpath\app.msi /qn , we get a windows prompt asking if we want to allow that to run (this is not UAC that is off).

I've tried addint the server in installpath to the internal sites in IE and it still prompts, the only way i can get installs to work is to upload them to shared files on kserver, write them to the local drive of the client and run the install from the c:\ but that is only feasible for tiny applications and bad practice at that.

What am i missing ?

All Replies
  • Some installers don't/can't run from a network path, I find that its generally better to have a file server/NAS host the setup files and then to download them to the machine that needs the setup file.

  • Are you trying to call the .msi directly? or have you tried msiexec /i \\pathtoapp\ /qn ?