Kaseya Community

NTVDM CPU error

  • I created a Virtual XP machine to test out some scripts before they go live and many of the scrips that involve downloading and installing software from the internet fail on the installation part.  I found it downloads the files into the Kaseya working directory and if you manually try to run it I get a 16 Bit MS-Dos subsystem box with the error NTVDM CPU has encountered an illegal instruction.  I thought it might a vmware problem so I tried on a different machine and recieved the same error.  Any suggestions?

     

    Matt

  • I am receiving the same error even on Windows 7 machines.  Support even told me to upgrade to agent 6.0.1.1

    Mark

  • I found out my problem.  I was using scripts provided with IT Center but some of the download locations were not accurate anymore.  It seems if the script can't find a file it just creates a bad exe file with the right name which produces this error.  I modified the location to download the file and the script worked.  For example this is the new url I use for the "Get Url" command for the download and install Malwarebytes script: www.regnow.com/.../visitor.cgi  

    Also note if you use the malwarebytes scan that it checks to see if version 1.37 is installed and if not it reinstalls it.  WE are on version 1.50 now so that line caused problems too.

    Matt

  • "It seems if the script can't find a file it just creates a bad exe file"

    That's not cool. I would have hoped the script would fail.