Kaseya Community

Unable to get exe installer to run in AP.

This question is not answered

I built a procedure to copy the installer from the server, to the kworking folder, then to run it from there. But it gets as far as copying and won't run it. I'm pretty sure it's how I have the execute/run command written out, but I'm not 100% sure. Here's what I got: 

run "#vAgentConfiguration.agentTempDir#\Client-Win.exe /qn /norestart"

^^ I'm pretty sure this is the cause, I've tried various strings trying to get it to work, but I'm not getting anything to work. The log isn't much help as it tells you it was a success. 

I have read that exe's are different to run compared to MSI's in Kaseya, but I haven't seen any posts on what to use in the case of it being an exe. Could you tell me what I'm doing wrong and how to fix it? Thanks!

All Replies
  • A screenshot of your script could help better assist you in the community.

    First I step I would recommend is to use double quotes at the beginning and end of the line.  Looks like you only have one set.

    run ""#vAgentConfiguration.agentTempDir#\Client-Win.exe /qn /norestart""

  • You could try a sanity check by transferring the file to somewhere else like C:\temp and trying to run it from there.  In a few instances I've had to create .bat files in order to run an .exe so I'll transfer the .exe and .bat to C:\temp in a new folder and execute the .bat as a shell command.  

  • Most installers allow for logging of the installation process and I'm sure this installer is no exception.  If in doubt as to what command line parameters are available, and the form they must take, a good old-fashioned "client-win.exe /?" in a command prompt will usually give you an excellent idea of what you can/can't do.

    To be 100% certain we get the command parameters correct we'll usually invoke the installation wizard and then modify the resulting procedure to use the correct (or preferred) path variables.

  • I added the quotes, I really didn't think it'd do anything because the other script I have for MSI installers didn't need it. Needless to say, adding the extra quotes, didn't work at all. The installer, only requires you to click install, and it extracts all its data. 

  • ,   I see a couple of issues.

    1)  You are trying to execute a shell command but referencing a shared drive "\\Lenses".  It is likely that you have a permission issue.   Does the file actually transfer? if so, you are good.  If nothing is there, then you will need to fix that.   You can try to change the permissions on that share to EVERYONE, or  attempt an "impersonateUser" command right before it.  You may be better off hosting that file somewhere outside of the customer site on the internet, and use the GETURL command.   If the file is small, then you could upload it to the VSA and use the WriteFIle command to push it down.    Network Permissions are always a pain in the ***.

    2) Line 3 - Why are you using a shell command to run this?   Use "ExecuteFile" and put the switches in the Arguments box.

    You could put some error trapping in by using the "testFile" command to make sure it is there before you try to run it.

  • It does copy over to the designated folder, for extra measure I did re-route it to the Temp folder instead of kworking. I have tried the "ExecuteFile" command, but I get the same error.

    I however, haven't tried the testfile command. I will give it a shot!

  • For an .exe i usually use runshellcommand instead and use "start C:\temp\Whatever.exe" or I'll make a bat file with that command and use the shellcommand to run the bat C:\temp\install.bat.

    I especially had to do this with a installer that used InstallShield.  Since I needed it to read the answer file I created the bat file with the full command line and used the runshellcommand to launch the bat file.

  • Use ussf to see if there are any arguments that can be used. I have had this trouble recently even though there were some.

  • I tried this as well, and was not able to get it work work. I'm starting to suspect it's the computers, so I will get them manually installed for now. It's only three, but I thought I'd try and save me some time lol. (Didn't happen since I've been trying to get this fixed for a day now) - I would like to thank all of you though for your input, and I will continue to try this out when I have more time! Thank you!

  • Are you sure that program can be installed silently??  Some vendors are archaic and don't!  You are probably right, for 3 systems, it would be faster to just do it manually.     Or just use Kaseya to copy the file to the local folder and then jump on and run it.

  • Have you tried using Software Deployment?

  • Software Deployment is broken, and doesn't support the file for some reason.

    @Chris, I'm starting to think that it can't. But not entirely sure. When you launch the installer, it unpacks the data and prompts you with the option to install or cancel. The only thing that was working with my procedure was the copying part lol. So that was easy enough to get to