Kaseya Community

uninstalling software

This question is not answered

I'm trying to remove software remotely and nothing is working.  I've tried the "uninstallbyProductGUID" method on WinRAR and IBM SPSS, neither works.

I've tried remotely executing the uninstall.exe for WinRAR, which also didn't work.

Has anyone been able to actually remove software remotely with Kaseya?  If so, how?

All Replies
  • When remotely executing the uninstall (assuming via execute Shell/Powershell/VBS). Are you running the script with the right permissions. There are four options.System, System (x64), User, User (x64). Try other ones. The permissions I mentioned is a Procedure Property called "Run As"

  • Unfortunately it varies product by product depending on the install method.  Programs that install with MSI files are the easiest as those respond to the Uninstall by GUID easily.  if you start getting .exe installers written by Installshield then the process gets trickier.

    One way to get an idea of what your uninstall should look like would be to go into Live Connect and check the Software section (Assetss > Software) and look at the Add/Remove section.  It'll show the uninstall string for the programs which should help.

  • Yes, we do this a lot.

    Get your GUID here:

    Get-WmiObject Win32_Product | Where { $_.Name -like '*WinRAR*' } | Select-Object -expandproperty IdentifyingNumber

    Feed the detected GUID at UninstallbyGUID