Kaseya Community

Having issues with zipping a file and a folder together

This question is answered

My issue is I'm creating a procedure to deploy Adobe Captivate.  The install zip is 2.4GB and when I try to upload that through the file manager it fails.  We're on SaaS so dropping it onto the server isn't an option unless there's some undocumented way to do that with SaaS.  So I unzip the install and it has a 1.06GB zip file of image assets along with the rest of the install files.  I've been trying for 3 days now to upload that gallery zip through the file manager and it's failed each time (this morning it failed at 99%).  So I got the bright idea to split the zip into two files,  leverage VSA unzip those to a directory on the computer and then re-zip it.

Here's where the problem happens, I unzip the two zips to C:\Temp\CPTV11.0.1, inside that folder is a folder and a single index file I need in the new zip.  if I use zipDirectory it's creating a zip of the folder CPTV11.0.1  rather than just the folder and file I want inside.  On top of that it's also adding in another folder in C:\Temp that shouldn't be added.  The line in the procedure is just

zipDriectory("C:\Temp\CPTV11.0.1\", "C:\Temp\Captivate\Build\HD\CPTV11.0.1\AdobeCaptivateGallery_x64-mul.zip", false, "All Operating Systems", "Halt on Fail")

The contents of CPTV11.0.1 are a folder named 4 and a file named AdobeCaptivate11Gallery_x64-mul.pimx.  Those two items just need to be in a zip named AdobeCaptivateGallery_x64-mul.zip.  Because it's a folder and a single file I haven't been able to use the zipFile command.  zipDirectory is zipping the CPTV11.0.1 folder itself plus another folder in C:\Temp that shouldn't be included.  

Verified Answer
  • Finally got the file uploaded.  I've been using Agent Procedures > File Transfer > Distribute File > Manage Files.  Instead I went through Agent Procedures > Manage Procedures > Schedule/Create > Manage Files which loaded significantly faster.

All Replies
  • This doesn't really answer the specific question that you're asking, but may be a solution for you anyway.

    I was having similar problems uploading some Office files (one that was .9GB and one that was 1.5GB). They would fail every time that I tried to upload them to the SaaS folder.

    I was thinking that the problem may have been related to a timeout, so I attempted the upload from a location with a 100/100 fiber connection to the Internet and they both uploaded perfectly.

  • I'm doing it from a 50/50 connection so speed "shouldn't" be an issue.  Part of me wonders if it's the VSA site timing out from inactivity since I'm not actively using VSA at the time during the upload.  I actually tried the last two nights starting the upload significantly after hours (11pm) and came in to a failed upload and the main VSA window at the login screen.

  • Finally got the file uploaded.  I've been using Agent Procedures > File Transfer > Distribute File > Manage Files.  Instead I went through Agent Procedures > Manage Procedures > Schedule/Create > Manage Files which loaded significantly faster.