Kaseya Community

Install fails to run but runs fine from command line

  • I'm having an odd issue with an InstallSheild installer and the associated .iss file.  I manually ran the installer originally from command line to create the .iss response file.  I have Kaseya set to drop everything in a temp folder but I'm having an issue getting it to execute the installer.

    In the procedure I have

    executefile("C:\temp\PowerSell 5.7\PowerSellV572060.exe", "/s /f1C:\temp\PowerSell 5.7\powersell.iss", "Execute as User and Continue", "All Operating Systems", "Halt on Fail")

    Running this procedure I get a report of success but the install is not completed properly.  The application folders are missing most of the files.  However if I run the executable with the flags from command line there's no problems at all.   I run PowerSellV572060.exe /s /f1C:\temp\PowerSell 5.7\powersell.iss  as a line in the command prompt for C:\Temp\PowerSell 5.7 and it silently installs with no issue.

  • I have had similar issues with this before and it usually has to do with spaces in the path of the file. I would recommend changing this part:

    /f1C:\temp\PowerSell 5.7\powersell.iss

    to this:

    /f1"C:\temp\PowerSell 5.7\powersell.iss"

    and see if that resolved your issue. Pretty much encapsulate the ISS file path in quotes.

  • Unfortunately that didn't work.  I'm trying a few different combinations, even trying changing it to C:\Temp\NewPowersell right now.  Hopefully I'll have a confirmation on a solution soon.

  • I would try the execute shell command option as that is what I favor over execute file.

  • I was having some odd issues using the executeShellCommand directly with the switches but the easy solution was to create a simple bat file with the line start C:\temp\NewPowerSell\PowerSellV572060.exe /s /f1C:\temp\NewPowerSell\powersell.iss and that runs perfectly fine.  I was able to use the same method for the sister program to PowerSell that I needed to also create an install procedure for.

    Problem solved, now on to the next issue!

    Added that problem was solved
    [edited by: trevor.okazaki at 8:21 AM (GMT -7) on May 18, 2018]