Kaseya Community

Kaseya Updates breaking Agent Procedures

  • I wrote a new Agent Procedure to activate Office 2010 for me last year (had an older one that only worked on 32bit OS's before that) and it worked great I tested it on Window XP 32bit and Windows 7 32/64bit last year in November and I know it was still working back then and in early January.

    This morning I had to remotely activate Office 2010 on a computer and this procedure stopped working. I traced it to the Windows environment variables (%ProgramFiles% and %ProgramFiles(x86)%) I was using to test if "ospp.vbs" file existed. I use the Program Files variables because sometimes this folder is redirected to another drive (that is not the C: Drive) so its intended to make the procedure more robust.

    I know this procedure worked before because I can recall the time I took to test it before I published it so the only reason I can think of why its no longer working is because an update was released that broke it.

    This is not the first time Kaseya updates has broken my agent procedures and I'm really fed up with this. Angry This is absolutely no good Agent Procedures are a core component of Kaseya and changes like this can cause serious problems.

    Kaseya Stop breaking my stuff!!!

  • Mate ... Ditto .. I've had the ExecuteVBscript step break .. and in SD all my SQLReads broke.

    I have a sneaky suspicion SD Change procedures are a bit flakey at the moment a well.

  • @HardKnoX & @Paul Haaker,

    Can you please submit tickets for these issues? Please include the procedures and any VB scripts you use, as well as examples of how they're supposed to work and where they break. As always, please let us know a couple of example machines we could test them.

    Ping back here with the ticket numbers, please


    - Amado

  • Thanks Amado

    The VBScript one I think was resolved as they just "magically" started working again . The ticket I logged was CS147208

    The Ticket Change issue is logged under CS148296 and is being worked on at the moment

    I think the bigger issue is the simple fact they broke ..

    It seems changes are been made to the Editor/Runtime that fix one problem and introduce 2 more

    I must have spent 1 full week trouble shooting and trying to find work arounds to fix problems that previously didn't exist ... and now will have to go back and remove my work arounds once hotfixes are released ... but as per Hardknox ... chances are it will all break again so very nervous about the whole thing which means I'll just spend the next few weeks checking and rechecking it hasn;t broken again

    VERY frustrating


  • @Amado already logged a ticket for this, the real issue that needs to be looked into and resolved has nothing to do with our scripts but with changes made to the Kaseya environment that causes our scripts to break.

    Kaseya is suppose to make our lives easier not harder.