Kaseya Community

"If User Logged In" not detecting logged in users.

  • Have a script (installs an MSI file) in K2.  It has a If/Then statement If User is Logged in (the "user" field is left blank) then it proceeds with the install, if not reschedules it.  This script was created using the MSI installation wizard.

    Regardless if a user is logged in or not it goes straight to "else" and reschedules.

    I have tried it logged into my sample machines locally, via RDP, and via KVNC.  No difference.  Machines are Windows 2008 R2 Standard both as hyper-v guests and as physical machines.

    If I change the If statement to just "True" the script does what it is supposed to do.

    What am I doing wrong here?


  • Kaseya uses the "KaUsrTsk" task to tell if a user is logged in . if this task is not running then kaseya doesn't think anyones logged in

    Im sure this will be your problem 

  • Dang - I wonder how often the startup item for KaUsrTsk gets removed? It must happen all the freaking time. That almost makes me want to create an agent procedure that recreates the startup item once a week or something.

    [edited by: SMason at 5:01 PM (GMT -7) on 6 Aug 2012] Word change.
  • Hi,

    Don't forget to put the parameters KaUsrTsk.exe" -remote in the startup for seeing the first user connected in RDP...

    I've got the same trouble, the KaUsrTsk.exe as been deleted , so i've do this step :

    1. Create new package with the /r (reinstall) for my Agents, and deploy with the User gpo or Machine
    2. Check exception in Antivirus correctly set for kworking directory and kaseya directory in %programfiles(x86)% 
    3. Check the state of windows explorer called in french "Prévention de l'execution des données" (I don't have english Windows to tell you the name, but in the advanced properties of the system you'll find it)

    Etienne Deneuve
    French Kaseya Certified Administrator
    67 Bld Richard Lenoir
    75011 Paris 

  • Hmmm...

    I have one (or I should say at least one) machine on which the KaUsrTsk.exe process is running just fine as the logged on user.

    If I run KLC, I can see the task in the taskmanager, as well as a bunch of other tasks the user has running.

    The VSA however, reports the machine as online without a logged on user.

    As a result my script to shut down a machine after Automatic Patch installs when there is no user logged on figured there was no logged on user, and promptly shut the machine down.

    Anybody have something similar, in which a user that's logged on is not recognised, but the KaUsrTsk process is running?

  • The system can recognize EITHER a local user OR a remote user.  Currently, it cannot recognize both.  Therefore, if an endpoint is generally used as a local workstation (which is the Kaseya default) then a user who is logged into the local machine should register as logged in.  However, if you were to remotely connect to this endpoint and login, that remote user would not be recognized as logged in.

    Conversely, for machines that tend to be remote (servers in a data center, VMs, etc.), those will default to recognizing a local user.  If you need to configure the recognition of a remote user, you must add the -remote tag to the registry (see community.kaseya.com/.../adding-the-remote-tag-for-kausrtsk-exe.aspx).  Once added, a remote user would be recognized as logged in, but if a user logged into the machine locally, the local user would not be recognized.

    Feature requests have been submitted to recognize either a local or remote user, but at this time, you'll need to determine which is the more likely scenario and add the -remote tag for endpoints where users are more likely to be logged in remotely than locally.  Adding this tag does require a reboot to take effect.

  • Well, for some strange reason the computer is now recognizing the logged on user. Nothing's changed on the machine, though.

    Oh well. Just another one of those weird things you come across every now and then, I suppose.

    BTW, the kausrtsk was set for local users, and this user logged on locally.

  • This happened to me the other day. I forced an agent update and it fixed it.