Kaseya Community

Windows7/Windows 2008 service monitoring

  • I'm having a really hard time monitoring services on Windows7 and Windows 2008 machines. What frustrates me the most is that some work and some don't, even on the same machine.

    One example: I have a service monitor for Trend Micro Server services. This works on our SBS 2008 box. I have another monitor for the MSExchangeIS service. This one does *not* work on our SBS 2008 box. However, that same MSExchangeIS monitor works on another SBS 2008 box. The two boxes are running the same version/build of Windows.

    Also, simple service monitors such as DHCP client and Time service fails on my Windows7 boxes.

    The AgentMon.log file does reflect the added monitor (i.e. servicename=w32time), but it doesn't reflect that any service events was uploaded to the server.

    edit: I just found that that if I stop and then re-start the service after the monitor set has been applied, it'll get picked up. I don't want to test that on a live SBS server, though, but it appears to be a sort-of fix to the problem.

    Legacy Forum Name: Windows7/Windows 2008 service monitoring,
    Legacy Posted By Username: Lmhansen
  • Good to know, I was having the same problem, applied the "fix" and it did indeed start working.

    Legacy Forum Name: Monitor Sets,
    Legacy Posted By Username: VNET
  • We use the KASM monitoring that rules out these errors.

    It picks only those services which are there on the box and setup as automatic.

    Legacy Forum Name: Monitor Sets,
    Legacy Posted By Username: mnagra