Kaseya Community

AgentMon.exe will not die

This question is not answered

Hi Guys,

 

We have an issue occationally that a server will appear as offline in kaseya, we connect in through another server and see that the service is stopped. Try to start the service but it does not let us. Checking processes tab in task manager AgentMon.exe is running and using lots of ram (50mb odd) I then try to kill it so I can start the service again but it will not die.

 

Have tried

pskill %process%

wmic process %processid% delete

End process tree

 

Does anyone know a way to be able to kill AgentMon.exe when its in this hung state and then start the service again or do i need to restart the server each time?

All Replies
  • This has been addresssed a few times, don't kill the process, restart the service, it's works a lot better.

  • If you are looking for a util to manually kill off proccess, look at ENDITALL.

  • Yeah this has been an issue since K2 came out. I have been told several times that they have fixed and to apply updates however the every time I get the update to fix it it breaks something else. I have traced the issue to mostly  Live Connect sessions crashing

  • The problem is the service has already stopped. The exe is still running for some reason but you can't start the service again until the exe is killed.

  • Hi Shickey,

    Thanks for the suggestion, ill give it a try.

  • Also, if you are trying to delete the agent file but it is locked, look at UNLOCKER.

  • Did you ever find a solution to this issue? We have the exact same issue and our plan is to move to K2 in the near future but for the time being I would at least like to know if anyone has found a way to kill agentmon.exe so that I can start the agent service without rebooting the server.

    Presently I have a server that I don't want to reboot at the moment, agent service shows as stopped however when you look at processes in task manager agentmon.exe is running and all attempts to kill it have failed.

    I have tried to kill the process using task manager, pskill, enditall, and Ultimate Process killer.

    Any sugestions?

    Thanks

  • Did  you try just restarting the service?

  • Have seen this problem hundreds of times and the only way to fix it was a server reboot.  Have logged tickets but by the time someone looked the problem was gone.  Not just a K2 problem either as our techs see this almost daily on our 5.x system.

  • Yeah I am hoping this problem will not exist in K2 we are also on 5.x and run into this at least once a week or so and the only way to resolve is to reboot the server. Kaseya any sugestions?

  • I had this issue on few of the servers, the fix I discovered was to reboot the server. Un-Installing and re-installing agent did not work either.

  • This doesn't explain what is happening specifically with Kaseya, but might give an insight into why 'unkillable processes' occur and what might be going on here.

    blogs.technet.com/.../unkillable-processes.aspx

  • Fellow Kaseyans,

    I had this issue today and it turned out to be a problem with my customer's F-Secure Anti-Virus. One of its services was hung, and once it was stopped, agentmon died right away.