Kaseya Community

How can I enable remote control of a VSA agent?

This question is answered

One of my employees has disabled remote access to his machine. His K in the lower right corner of his system tray is in red. I've read another KB that says the only way to enable it is for that user to right-click the K and click on Enable Remote Control. 

When this user right clicks his red K, there is no option to enable the remote.

Please advise. 

Verified Answer
  • not 100% sure - but check the client agent settings for what shows on that particular machine and make sure that the enable/disable remote control option is authorized and then see if you can re-enable for that client agent directly on the agent ... once re-enabled (if this works) then remove the option for enable/disable again.

    Setting found in -- Agent / Configure Agent / Agent Menu ....

All Replies
  • not 100% sure - but check the client agent settings for what shows on that particular machine and make sure that the enable/disable remote control option is authorized and then see if you can re-enable for that client agent directly on the agent ... once re-enabled (if this works) then remove the option for enable/disable again.

    Setting found in -- Agent / Configure Agent / Agent Menu ....

  • Hello There

    Use this procedure to re-enable a disabled agent.

    Works for us.

    5875.Procedure Re-Enable_AgentRemoteControl.xml

  • You can adjust the policy for "Agent Menu" to allow the remote control enable/disable option. We have run into this a few times so we have made a policy for this. If we run into it, I apply the policy that has that agent menu option enabled to the machine so they can enable it, then remove it after im done. (Must re-process the policies when you do this)

  • I agree Policy Management is the way to go and works well in this kind of situation...