Kaseya Community

Impersonate User

  • I ran an Agent Procedure thousands of times with no issues (Cisco Umbrella RC installer). The Agent Procedure was provided by the vendor years ago, and only modified slightly. Thousands of endpoints get the RC through this installer with no issues.

    Now I'm troubleshooting an environment with a large number of non-domain devices and permissions errors installing the RC.

    I need this working at the top of the week, while both Kaseya support and Cisco support are horribly under-staffed for the holiday weekend.

    Kaseya seems to execute everything by default as current user, which has been a major thorn in my side.

    I'm installing the RC while end-users are currently logged in with inferior permissions.I don't have the option of interrupting hundreds of console sessions.

    Impersonate User simply isn't working for me. I inserted impersonateUser at the top of the script to no effect. Then inserted it immediately before the relevant executeShellCommand.

    "Impersonate User - Enter a username, password, and domain for the agent to log in with, when Execute as user... is specified using Execute FileExecute File in Directory Path or Execute Shell Command. Leave the domain blank to log into an account on the local machine."

    If it were only that easy. 

    Who's got experience here? I really need this to work. Thanks,

    ECMSP

  • Have you tried the "Execute as System" choice in most of the commands?