Kaseya Community

Cannot create registry DWORD value using a Kaseya procedure

  • Hi everyone,

    Sorry I am new to this and this might be an easy question. I am trying to set a DWORD registry value and am unable to. The error that I get is "Script Summary: Failed THEN in step 2."

    The DWORD value I want to create is called "JunkMailImportAppend". In the "Enter the full path to.." box I have: HKEY_CURRENT_USER\Software\Policies\Microsoft\office\16.0\outlook\options\mail\JunkMailImportAppend

    I have tried both the "set64bitregistryvalue" and "setregistryvalue" commands. The OS is Windows 10 64bit.

    The key where the DWORD should be placed already exists.

    I have tried rebooting the workstation after running the procedure. 

    Any help would be appreciated.

  • HI OWENB.

    First go to procedure and select the new procedure and select the setregistryValue .

    Enter the full path to a registry

    HKEY_CURRENT_USER\Software\Policies\Microsoft\office\16.0\outlook\options\mail

    Enter the the data write to registry value is

    JunkMailImportAppend

    select the data type is

    Reg_DWORD

    and save it and test it on machine.

    If you have any question please let me know.If you are not able to create the procedure you can send the email to pawan@technospecs.com i will send you to xml file or procedure.

    Thanks,

    Pawan

  • Same thing unfortunately. I thought the "Enter the data.." box was for the value of the DWORD ( such as 1 )?

  • My guess is that your actual problem is with the fact that you are trying to write to the HKEY_CURRENT_USER hive.  The standard registry commands built into the procedure engine are all running as the "System" user, and thus from it's perspective the HKEY_Current_User hive is *not* the same as the currently logged in user's HKEY_CURRENT_USER hive.

    Your best bet is to instead write out a command line way to set that registry key and then use the option in the procedure editor to run a commandline as the logged in user.

    For example using the built in REg command you could run

    reg HKCU\Software\Policies\Microsoft\office\16.0\outlook\options\mail /v JunkMailImportAppend /t REG_DWORD /d 0

    I haven't specifically tested it but that command *should* do what you need I believe, if you specify that specific command to run "as user" in the procedure then you theoretically should get the results you are looking for.

  • Is that your issue resolved or not?