Kaseya Community

KaseyaEndpoint.exe always crashes

  • Hi,

    We've opened a ticket with Kaseya support about this issue about a 10 days ago and so far the only thing they have told us is to "reinstall the agent" as if that wouldn't have been the first thing we tried...

    Issue:  for some reason on a "Dell Inspiron 3180", the "KaseyaEndpoint.exe" service crashes with error 0xC0000005.  We've tried clean installs of the agent, clean install of the operating system.  Tried different flavors of Windows, 7, 8, 10 included.  We even cloned a good laptop (different model) HD and put it into this machine and the endpoint exe still crashes.  We are already on the latest Bios, tried disabling secure boot, disabled the TPM, disable anything security wise we can think of and it still crashes.

    For those who don't know the "KaseyaEndpoint.exe" executable is critical to make any of the new Kaseya applications work, such as KRC, LiveConnect and the new KAV.  Note, KVNC, the legacy KAV, scripting all work fine.

    We have no idea what is causing this executable to crash nor has Kaseya been any assistance thus far.

    Ticket #: 183770

  • Best thing I would advise is to review do the following:

    1. The moment the service crashes, review the Kaseya Endpoint logs to see whether it's referencing a specific task that led to the crash.

    2. Enable full memory crash dump on the agent which will capture the point in time memory access violation that the service is apparently running into.

    Send those details to the ticket.

  • The computer itself isn't crashing, or BSOD.  The executable simply crashes and ends.  Dump isn't going to occur.  The only reference is 0xc0000005, which is already in our ticket.

  • There are also user-mode crash dumps which will capture the crash of the Endpoint service. These would be useful.