Kaseya Community

Using agent procedure to uncheck Require Server Verification (https:) for all sites in this zone

  • I've tried to create an agent procedure to change the registry key needed and it is not working, the procedure I tried is below

    <ScriptExport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://www.kaseya.com/vsa/2008/12/Scripting">
    <Procedure name="UncheckrequireHTTPS" treePres="3" id="1413986428" folderId="244874588514154" treeFullPath="myProcedures - btomski">
    <Body description="">
    <Statement name="SetRegistryValue" continueOnFail="false">
    <Parameter xsi:type="StringParameter" name="RegistryPath" value="Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\2\Flags"/>
    <Parameter xsi:type="StringParameter" name="Value" value="71"/>
    <Parameter xsi:type="EnumParameter" name="DataType" value="Integer"/>
    </Statement>
    </Body>
    </Procedure>
    </ScriptExport>
  • It looks like you are missing the begining part of the registry path. example: HKLM or HKey_Local_Machine

  • Hello Btomski,

    Our documentation states you need to include the full registry path:

    So the following will work:

    However, please note this will not work on 64-bit machines, I recommend always doing the following when running scripts for registry edits:

    Hopefully that gets you started.

  • Thank you both for your help, I'm going to correct it and give it a shot!

  • Thank you, that corrected my error but it is writing the key as hexadecimal is there a way to modify so it is a decimal instead?

  • Procedure Folder Require Server Verification.xml

    This is for Trusted Sites. Change the below to the correct number for the zone you want

       Value    Setting
       ------------------------------
       0        My Computer
       1        Local Intranet Zone
       2        Trusted sites Zone
       3        Internet Zone
       4        Restricted Sites Zone

    https://support.microsoft.com/en-us/kb/182569
  • Rusty I appreciate the 2 procedures attached unfortunately that completely disables the trusted zone option and unfortunately left the box checked.