Kaseya Community

Screencapture agent procedure

This question is not answered

Hi,

I am having the following issue:

I want to take a screenshot with CmdCaptureWin.exe. If I run CmdCaptureWin.exe with the /f switch in windows cmd. I will get a good screenshot.

But when I use CmdCaptureWin.exe in a kaseya script I will get a black screenshot. Also if I use liveconnect I will get a black screenshot.

Is there a way to get this to work?

Kind regards,

Christian

All Replies
  • I don't know a good way to answer the issue that you are seeing right now, but I will say that I actually went away from using any of the screenshot utilities built into Kaseya.  Mainly because they only the "Screen 1", and 99% of our clients these days are running multiple monitors.  As such I wrote my own Kaseya procedure using nircmd (nirsoft.net)  to do the screenshots. It will get *all* attached screen in one image.

    It's as simple as running "nircmd.exe savescreenshotfull filename.png" then grabbing that PNG file.

  • I'm suspecting that you are using UseCredential for this.

    You will need to execute the command as the user context. If this runs with the "Set Credential" account or any other account such as System, you will be producing a blank screenshot because that account's desktop is usually hidden.

    The same reason why running scripts with prompts as System will cause a script to "hang" because no one is there to see the actual WScript prompt.

    Ensure you're running as the local user and also ensure that the Kaseya Helper (KaUsrTsk.exe) is running as well. I've seen it in the past that if this process is not running (aka logged in via RDP) all commands running as the current user will fail to run as the current user.

  • I would imagine that flavio is correct.  I never even really thought about that aspect but I *am* running that nircmd script specifically with "Execute as User".

  • I've never had a problem with Kaseya's built in captureDesktopScreenshot command. Just create a new script, and under System you'll see captureDesktopScreenshot. Mine is set to Silent Capture and perform steps on all OS and Continue on Fail. The user must be logged in and you can view the file in KLC>Agent Data>Get File.

  • I also tried nircmd.exe. But it didn't work.

    I have searched the internet and I found a tool called boxcutter. That seems to have done the trick.

    Thank you all for your replies!

  • I would check that process with ProcMon and see what user context it runs under.

  • I'm kind of new to this, but ran into a similar problem. I recommend using a 3rd party screen capture as well. Any freebie/freemium seems to work.