Kaseya Community

Unable to install agent

  • Hi,

    I have a problem installing agent on one of our computers. The error says "An installation Support file could not be installed". Interface not registered" and then ends with the error "Installation of Virtual Administrator Agent Failed".

    I tried running it as administrator (Run As) that didnt help either.

    Any ideas?

    Regards,

    Kumaran


    Legacy Forum Name: Unable to install agent,
    Legacy Posted By Username: kumaran
  • I haven't experienced this before, but it looks like the error message may be coming from Install Shield (the Kaseya Agent uses Install Shield).

    What OS are you using? Have you experienced this on more than one machine?

    Have youtried creating an Agent package that doesn't have the /s silent option to see if you get any more information?


    Legacy Forum Name: Agents,
    Legacy Posted By Username: raybarber
  • Hi Ray,

    Sorry for the delay in responding. Infact very long...:X

    It was a problem with Installshield. I looked into the Installshield KBase and tried their suggestions but it didn't help:

    Installshield KBase article:

    http://consumer.installshield.com/kb.asp?id=Q110609

    Investigating on this, I can only understand that the Installshield engine is not getting installed properly and thereby the agent.

    The system had Windows XP with no SP and I believe there was some core Windows Component which had a problem. Haven't installed the agent still.



    Regards,

    Kumaran


    Legacy Forum Name: Agents,
    Legacy Posted By Username: kumaran
  • Hi Kumaran,

    Seems I am a bit slow on replies too! Stick out tongueSorry, I didn't have a watch setup on the topic.

    I have seen a similar problem installing other InstallShield applications. I beleive the answer is in your reply, in that there is issues in the initial release of XP. If you put Service Pack 2 on these machines I beleive they will be fine.

    There may have been a fix from Microsoft before the release of SP2, but I do not know which MS update might fix this problem.

    Sorrythere is not much I can suggest other than this, as there is no problem with the Kaseya agent as such, so its outside my area of expertise.

    If you are still experiencing an issue, please send an email to support@kaseya.com


    Legacy Forum Name: Agents,
    Legacy Posted By Username: raybarber
  • Hi,

    I am having a simular error when installing the agent;

    An installation support file could not be found,

    The specified module could not be found.



    I tried to do the fix from the website that is postet in this forum but I was not able to install it. when I tried to do the fix, I get exactly the same error message.


    Legacy Forum Name: Agents,
    Legacy Posted By Username: Emiel
  • Hi Emiel,

    once again this looks like an InstallShield error, rather than a 'Kaseya' error as such. This would lead me to beleive this machine has an issue with it's install shield installation. The web link above to the Install Shield site should show how to reinstall Install Shield on that machine.

    If you are just experiencing this on one machine, then it is an issue with that machine, and perhaps reapply the lastest service pack, e.g. XP SP2.

    If this is happening on a number of machines and you are a signed up Kaseya customer then please email the support desk on support@kaseya.com and send a screen shot of the error message.




    Legacy Forum Name: Agents,
    Legacy Posted By Username: raybarber