Chrome Live Connect Plugin - Error 1701

  • Does anyone else get the following error when trying to install the Live Connect Chrome plugin?  I have already modified the registry key as previously noted to allow plugins to install.

    ERROR 1701: Install Failed: Install Failed : ChromePackaginFailed : Failed to package crx. Exit code: 21

    Does anyone know how to correct this?

    Thanks in advance.



    [edited by: eperson at 9:54 AM (GMT -8) on Nov 12, 2012] Correct typo.
  • I'm getting this currently, after a fresh Windows 7 install.  Saying that, I've also not been able to install plugins in IE either after this rebuild, so it may be that my problems are larger, but I'll be interested to see how you get on.

  • I had similar problems after loading windows 8 on my desktop last night.  I managed to work around it by going to oldapps.com and installing an older version of Chrome (21 I think). Havent tried upgrading Chrome after installing the Kaseya Addons yet but will probably do this today.

  • I did the exact same thing last night as well with win 8.

    Tried different versions of chrome, anyway managed to catch the plugin as it was downloading into the downloads folder on the earlier working version of chrome, save it and then install the latest chrome.  Then manually install the two plugins via drag and drop into the chrome extensions section.

    Pain in the *** but got it working with the latest chrome.

  • The latest version of Chrome I have managed to get going is version 21.0.

    Note that this version does not let you load plugins from outside the chrome store by default. You can work around this issue in one of two ways.

    1. Modify your shortcut to google chrome and add the switch --enable-easy-off-store-extension-install

    2. Download the plugins (.crx files) to your downloads folder, open up Chrome Settings > Extensions and drag the .crx file over to the extensions page. This will side-load the extension for you.

    Where I have run into problems is that the second plugin that Kaseya installs after installing it's download manager does not always download as a .crx file. This is easiest to work around by modifying your startup shortcut and just letting Chrome take care of it.

    Another plugin that I always load up is the ActiveX for Chrome plugin as this makes remote control work. With Windows 8 the Chrome store will not let you install this (but it did last week - thanks google). To work around this issue, go to the developer page for the ActiveX plugin, download it and then side-load it. The URL for the ActiveX download is code.google.com/.../list



    [edited by: ghettomaster at 2:53 PM (GMT -8) on Nov 12, 2012] .
  • I'm having the same issue with Chrome v23 on Windows 8. Unable to use Live Connect now.

  • I've come across this also.

    Download Chrome v22 MSI from here: bossdeploy.com/.../v22.0.1229.79

    Also download the reg to prevent it autoupdating

    Add -–enable-easy-off-store-extension-install switch to the program shortcut

    This is the only workaround that i have that works at the moment.

  • The issue is that google chrome is disallowing, by default, the install of third party (non google play webstore) extensions. There is a registry fix to allow this. I tried it on my machine and it seemed to work fine. Please see the hyperlink for the appropriate workaround.

    community.kaseya.com/.../77076.aspx

  • We have posted a KB article for the "failed to package crx" issue - community.kaseya.com/.../1078.aspx 

    This is different from the web store policy issue described in the KB referenced by Matt S



    [edited by: Dominic Walsh at 9:40 AM (GMT -8) on Nov 14, 2012] clarification
  • @Matt - The registry workaround you posted has the same effect as the enable offstore extension shortcut. As has been discussed this workaround is no longer working in V23 of Chrome.

    @ Dominic - I have tried upgrading to V23 after installing the extensions and they seem to get uninstalled for me. I did notice Chrome said something about "Your user installation has been replaced by a system wide installation by your administrator" so this may have something to do with it. I don't really have time to look into this though so i'll just downgrade to V22 again and get on with the day I think.

  • Any update on KLC Plug-Ins for Chrome V23?

  • I got it working by installing Chrome 22, installing the KLC plug-in, then upgrading Chrome.

  • Chad - what OS are you running and what installer did you use for V22?

  • You can get V22 at oldversion.com. I'm on Windows 8

  • I had the same problem....downgrading to V22 worked for me. Thanks for the solution!