Kaseya Community

Linux agent install: Fatal: Missing init.d or rcX.d directory.

This question is answered

Hi all,

Has anyone else had this issue: "Fatal: Missing init.d or rcX.d directory." ?

Linux ver 3.1.07.fc16.i686 - Red Hat 4.6.2-1 (Fedora) installed to disc within a vm.

chmod was performed, installer run from an administrative user in cli elevated to root via su. That said, I'm a fairly new linux user!

Thanks.

Phil.

Verified Answer
  • While its true Fedora 16 isn't an officially supported Linux distro, it falls into the unofficially supported category. So I created a VM and tried the installer on it. I had the same fatal error and looked into its cause. To make a long story short, its failing because this release changed the meaning and contents of the file /etc/inittab and that confused the installer. I'll fix the installer sources to this doesn't happen in future updates

    and releases.

    As for you, I have a quick work-around which will get around this problem. Simply rename /etc/inittab before running KcsSetup.sh (you can rename it back to /etc/inittab once you've run the installer if you want). However, if you do this now, you'll get a message about the agent already

    being installed. So you'll need to remove the partially installed agent before rerunning the installer. The partially installed agent is in the /opt/Kaseya directory. Please remove the entire /opt/Kaseya directory before rerunning the installer. Assuming /etc/inittab has been renamed, the install should work (it did for me).

    One further note: The agent icon is not supported on Fedora 16 or any Linux distro using GNOME 3. While the agent will run, you will not get the icon in a panel during login.

    Gordon - Linux Agent Development Team

All Replies
  • Hi Phil,

    Fedora 16 isn't an "officially supported" platform for the Kaseya Linux Agent.  From the online help: the supported platforms for Kaseya 6.2 are "SuSE Linux Enterprise 10 and 11, Red Hat Enterprise Linux 5 and 6, Ubuntu 8.04 and higher, and OpenSuSE 11. ....... While untested, the Linux agent is likely to work on other LSB-compliant Linux distributions published in the last few years." (help.kaseya.com/.../K2-System-Requirements62.htm).  

    You might want to try disabling SecurityEnhancedLinux with the command "senforce 0".  You switch it back on with "senforce 1".

    I'm planning on installing Fedora 16 in a few days.  I will try installing the agent on it then and let you know how I go.

    Regards, David.

  • While its true Fedora 16 isn't an officially supported Linux distro, it falls into the unofficially supported category. So I created a VM and tried the installer on it. I had the same fatal error and looked into its cause. To make a long story short, its failing because this release changed the meaning and contents of the file /etc/inittab and that confused the installer. I'll fix the installer sources to this doesn't happen in future updates

    and releases.

    As for you, I have a quick work-around which will get around this problem. Simply rename /etc/inittab before running KcsSetup.sh (you can rename it back to /etc/inittab once you've run the installer if you want). However, if you do this now, you'll get a message about the agent already

    being installed. So you'll need to remove the partially installed agent before rerunning the installer. The partially installed agent is in the /opt/Kaseya directory. Please remove the entire /opt/Kaseya directory before rerunning the installer. Assuming /etc/inittab has been renamed, the install should work (it did for me).

    One further note: The agent icon is not supported on Fedora 16 or any Linux distro using GNOME 3. While the agent will run, you will not get the icon in a panel during login.

    Gordon - Linux Agent Development Team

  • Awesome! Thank you Gordon. That did the trick! (Well, it did once I put my brain in gear after an hour in a windows command line environment, and stopped trying to use the commands 'rename' and 'delete' and remembered to add the -rf flag to the rm command...) :-)

    Much appreciated!

    Phil.