Kaseya Community

Constantly have to disable RCP/TCP when installing agents via LANWatch

  • Whenver i try to install agents through LANWatch i get a "Remote start Service failed Error 5: Access is denied."


    After a few tickets submitted, we found a work-a-round for the issue.

     

    I spoke with a LAN watch specialist and he said to try the following:

    For access denied error, you can ask customer to disable RPC/TCP on the lan watch machine by adding the 
    SCMApiConnectionParam with a value of 1 in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control 

    below is the Microsoft document about the settings: 
    http://msdn.microsoft.com/en-us/library/dd578505(v=VS.85).aspx


    The problem i having now, is that i have to do it for every site, everytime i want to push through LANWatch.

    Does anyone have any suggestions?

     

     

     

     

  • Josh,

    I have the same problem.   I was using a 2008R2 box as my LanWatch machine to push agent installs from.  This worked fine in the past with 2003.  I would suggest you push hard on Kaseya support for a solution.  It is not up to us as the end-users to supply work-a-rounds to something that should work just fine; and what they gave you is not a "solution" by any means.

    Ryan

  • After speaking with Kaseya they are aware of the issue. They said there is no fix for now. They said you have to use this work-a-round until the next release.

    I am waiting for a script from them to do this automatically.

  • HI Guys,

    FYI - After working w/ Kaseya Engineering, we have addressed this issue in our code and this will now be done in automated fashion and no manual steps are needed. We are simply preparing it for hotfixing. If any of you are interested in trying these changes out, simply file a ticket at https://portal.kaseya.com and note to have this ticket assigned to Dylan Lagi as I will work with you guys from there. Thanks.

    Regards,

    Dylan M. Lagi

    Tier 3 Support Engineer | Kaseya Support

    http://www.kaseya.com/support

  • Hello,

    FYI - Hotfixes have been released to address this issue. Using an appropriate account, visit the System > Configure page and choose to get latest hotfixes. Feel free to let us know how this functionality is working from here.

    Regards,

    Dylan M. Lagi

    Tier 3 Support Engineer | Kaseya Support

    http://www.kaseya.com/support