Kaseya Community

Linux SSH

This question is not answered

Since the update in 9.5.0.26, we had hoped that our SSH woes would have been resolved but we still cannot use Remote Control -> SSH to access our CentOS machines. I went ahead and built a new VM with nothing else on it other than the base OS and Kaseya Agent, tweaked the firewall rules to allow all traffic from the KServer and opened SSH to the VLAN on TCP 22. However when I launch SSH and run the activex agent it only goes to the countdown screen which never counts down. I have run tcpdump, netstat and watched the traffic on our firewall in front of the KsServer and I do not see anything except the heartbeats from the agent. I went ahead and disabled IPv6 on the agent so that I knew it was not interfering (we dual stack) with no luck either. I also pushed an account and password to the machine to verify it worked and it did. Nothing in the logs either. Any thoughts?

On-prem server running 9.5.0.27.

FirewallD rules:

[root@****-klt0623 tmp]# firewall-cmd --list-all
public (active)
target: default
icmp-block-inversion: no
interfaces: eth0
sources: <KServer ipv4 address>
services: dhcpv6-client ssh
ports:
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

All Replies
  • Unless I'm mis-remembering (which is entirely possible).  The SSH connection won't be coming from the KServer it will either be coming from the loopback address (127.0.0.1) if it uses the local agent, or it will be coming from a random kaseya agent on a different machine on the same network.  I don't remember for certain which, and I think it depends on exactly which "SSH" option you use...

    Someone else may have more info though.