Kaseya Community

Catalina compatibility

  • Do we have any firm timetable for Kaseya Agent being Catalina compatible?
    We had several users do the macOS upgrade on their own yesterday and now get "KUstTsk AgentMon failed to launch. Server connection failed, exiting."

    I had hoped that the update last week, which included "major architectural changes", was going to address Catalina compatibility.

    (ticket open, #460617)

  • I definitely second this one. The Mac users tend to upgrade themselves. And upgrade quickly. Apple pushes the upgrade hard and users have learned that if they upgrade, they'll get all kinds of new toys.

    A new agent, with an easy upgrade procedure to remotely upgrade everybody before we lose them sure would be appreciated.

  • There are a host of major changes in that release that will likely heavily impact your ability to remotely manage even mundane components of those devices. I would advise blocking the upgrade until you have understood the potential impact and how to manage it.

  • We have released a notice regarding Catalina.



    Edit link
    [edited by: Oscar Romero at 2:36 PM (GMT -7) on Oct 9, 2019]
  • @Oscar, the link goes to a page that returns:

    Group Not Found

    The requested Group cannot be found.

  • Appreciate the heads up - I have updated the link.

  • Doesn't work for me. Takes me to a logon page then hangs.

  • Same here. Goes to the helpdesk site and asks me to login then just says kaseya.zendesk.com refused to connect.

  • Will there be any issue with the endpoint certificate on Catalina as well? It seems that certificates must have a validity period of no more than 825 days on Mac OS 10.15 and from memory, the endpoint certificate has a validity period of 100 years?

  • I was finally able to view the linked page using Firefox. Chromium based browsers are not processing the login process properly.

    To save anyone else the trouble, here is the text from the page:

    helpdesk.kaseya.com/.../360034578352-VSA-Support-for-macOS-Catalina

    VSA Support for macOS Catalina

    Avatar

    Valerie Trenholm

       Created: 2 days ago, Last Update: 1 hour ago

    Important information regarding VSA support for macOS Catalina:

    Apple macOS Catalina (aka macOS 10.15) is now available. The Kaseya VSA agent currently is not compatible with Catalina.  Please be aware of this if you are planning to upgrade your macOS systems to the Catalina release.

    The Catalina release will only support 64-bit versions of applications, which means 32-bit applications will no longer function. The Kaseya VSA agent is currently a 32-bit application only. We are in the process of re-architecting the VSA agent to support both 32-bit and 64-bit macOS platforms, including Catalina.

    We plan to have a new, limited functionality macOS VSA agent that will be compatible with Catalina (10.15) available as a Beta release in early Q1 2020.

    You can find the operating systems and versions that are currently supported by the Kaseya VSA agent here.

    We will provide updates on the new agent in the coming weeks.

  • How do we connect to a Mac OS in the mean time? I have never been able to connect via VNC.

  • Has anyone received an update from Kaseya that is more recent than 10/10/2019?

  • If the Mac is on Catalina, you can't.

    The only RMM solution I'm aware of that's working for Catalina is JAMF.

    I've even had problems with logmein on Catalina.

  • The KB article will serve as the uniform source for any Kaseya updates regarding Catalina.  This is why we encourage to review the article.