Kaseya Community

Kaseya Agent on Windows XP

  • i have problem when installing agent on windows XP

    anybody here facing same issue?

  • Why are you connecting to an XP machine?

  • XP reached Microsoft's official  "End of Life" status 5 years ago, on April 8th, 2014.  With the exception of the so called "highly unusual" WannaCry patch in May of 2017, it has not received any security updates since it went EOL.  Support for XP Embedded SP3 ended in 2016.

    So the official answer is, XP is "not" supported... as Kaseya could not officially support any OS that isn't supported by its maker.  The very presence of systems running unsupported operating systems connected to any network is a potentially significant security risk to the entire infrastructure.  Even if you get the Agent to install, there will be elements of the Agent architecture that just will not work.

    If I were an MSP, I would consider requiring any customer still running XP anywhere within their environment to sign an indemnification agreement stating I can not guarantee the safety of any deprecated OS, or any systems within any network where these systems are connected.  Besides provided you some cover, it will also express to the customer just how serious the risk is.

    Kirk...

  • To piggyback off of Kirk's response, we have updated our agent requirements documentation as well:

    help.kaseya.com/.../index.asp

  • @lfairbanks we install 50K, 10% of it was legacy machines. and we need to know how many machine still using XP and we want to replace it with a new one., so we need to install on every single machine

  • so it's already official right that kaseya no longer support XP?

  • I was just asking because I know some companies have software that will only run on XP and they keep those sandboxed for security.